MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 Pull-up Resistor on WE# - AM29F080 - SOLVED

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List Spell Checker
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File
Check here to include your profile signature.
    

T O P I C    R E V I E W
teknix1 Posted - 09/27/2016 : 10:12:45
Hi,

I'm not going to go into too much detail about my project but I am trying to program an AM29F080 that has a pull-up resistor (2.2K) on the write enable line (WE#). This is obviously to disable the write function while it is used as a read-only device. Somehow when I place this device in my programmer (GQ-3X Re-1.00) using my home made adapter, it is unable to identify, erase or write to it. I am however able to read it. In my design, I also have a 2.2K pull-up resistor on the RESET# line. This one is not causing me any issues though. Both of these resistors are connected to pins 10 and 31 of the AM29F080 (40-Pin Standard TSOP). Would anyone have any idea why this pull-up would cause these issues?

Second quick question, if I take out the resistor on the WE# line, my chip works perfectly in my read-only environment, is this a good design? Can it be left floating like that?

Thanks in advance
Nic

3   L A T E S T    R E P L I E S    (Newest First)
teknix1 Posted - 10/03/2016 : 11:16:35
Well I just figured it out. I wasn't tracing /WE properly, it goes through J5 and U1 (74HC244) on the ADP-082 board. I hadn't mentioned this board because I didn't think any of the traces were going through logic, my bad. So switching from V2.0 to V1.0 made everything work. 74HC244 is a buffer, I'm going to guess if plays with the timing of the signal.
teknix1 Posted - 10/03/2016 : 09:19:40
Thanks ZLM, yes that was my understanding as well. I would really like to leave the pull up resistor in place as it makes sense. Then what about programming the chip while that same resistor is in place, is there a way? I am trying to trace the WE line on the programmer board, but it's a bit hard to follow, perhaps if I could have a look at the schematic... Is this available anywhere?

Thanks
Nic
ZLM Posted - 10/01/2016 : 14:09:52
The pull-up is used to prevent write data accidentally. If this line is floating, then the chip may still reading fine, bu is not under protection, sometime the data may be altered by noise.

MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.09 sec. Snitz Forums 2000