MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 Issues With AM29F032B-75EC

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List Spell Checker
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File
Check here to include your profile signature.
    

T O P I C    R E V I E W
teknix1 Posted - 10/07/2016 : 16:07:43
Hi,

I am trying to write to an AM29F032B-75EC and just not having much success. I've seen a similar problem with this chip being described in another thread, but the solutions offered there do not work for me.

I can erase and blank check the chip, that works fine every time. When I write to it, I get failures in the verify step at what seems like random addresses. The odd thing though is that the failure is always when it is supposed to write FF. I can try writing it multiple times with the same settings and the failure points are at different addresses. The first 15% or so is always correct though. I've also tried this at different speeds but the outcome is always the same, random wrong writes. I have tried writing the chip using two different adapters ADP-082/ADP-077 and my own adapter and the behaviour is the same, so I know this isn't related to the socket on the ADP-077. On the ADP-082, I played with the jumpers:

J1 and J2: need to be closed or else it doesn't ID, write or erase
J3: 3V or 5V, I seem to achieve the same result, I did notice a lot more bad bytes on one test using 3V and -2 writing speed
J5: Needs to be on 1.0 or can't ID

I am using an older programmer, GQ-3X (Re-1.00) with the last version of the software that supports it, 5.03B. First off, this device does not exist in the devices.txt, so I added the following line:

Name="AM29F032B*TSOP40",ID="04D4",Class="29F040B",Category="FLASH",MFG="AMD",CodeSize="4194304",DIP="100011110101",Adapter="TSOP40B-DIP32";

I would love to understand those DIP switches, if anybody has the documentation, I would appreciate if you could post it. The real ID for this chip should be 0141 but it is always returning 04D4. I've seen this in another thread as well.

I usually end up with about 30 or so wrong bytes across the 4MB, is there a way to just write one byte at a specific address? I don't even know if this could be a temporary solution, but I thought I could try re-writing only the bad bytes.

Thanks in advance
Nic
10   L A T E S T    R E P L I E S    (Newest First)
teknix1 Posted - 10/14/2016 : 14:59:57
I had no idea this was even possible. Definitely, I need to learn the inner workings of cmos cells. However, I still think the programming part is still correct as the chips works perfectly my application or is that just luck... I'm not quite sure where to go from here. Perhaps I should try buying new chips.
anniel Posted - 10/10/2016 : 04:03:27
No the chip. The CMOS cells are probably not shifted to the right voltage.
teknix1 Posted - 10/09/2016 : 18:12:20
Hi anniel, could you clarify a little? What isn't reliably programmed? I can confirm the chip is correctly programmed in my case, so are you talking about the programmer's firmware?
anniel Posted - 10/09/2016 : 15:56:27
Yes, it is not reliably programmed.
teknix1 Posted - 10/09/2016 : 12:17:29
Ok, I've worked quite a bit at this issue today. I realized by pressing the verify button multiple times that it does not always fail at the same address for a single write. So I started wondering if the issue was with reading instead of writing. After programming it, I read the chip multiple times and compared the results to the original file using a compare tool. I can confirm the failed reads are not at the same addresses between reads. So I wrote a quick app to compare about a dozen files with the source. This confirmed my new theory. With enough reads, I can actually validate the entire binary. I also tested the chip in my application and it works.

Anybody ever heard of failed reads with the AM29F032B-75EC? Or with any other chip?
teknix1 Posted - 10/09/2016 : 09:53:01
No need to reply about the power adapter, I just realized the board is labeled. I checked the 5V on my chip while it was being programmed, I saw it fluctuate well outside of the recommended range. I'm talking less than 4 volts. So I tried 2 power adapters I could find at home that fit the requirements, one was 12 volts, poor 7805, I had to add a heat sink. But still no luck, I get failed writes every time. The Vcc was however very stable with a power supply attached.
teknix1 Posted - 10/08/2016 : 15:23:41
When you asked me if I had tried other chips, did you mean the same chip number or any other chip? I have programmed a number of other flash memories before, AM29F040 AM29F080, never had issues with those.

Is it worth upgrading the firmware on my programmer, is there a chance it might fix this issue?

I also read in the datasheet that the -75 variant of this chip requires a more stable Vcc, 4.75V to 5.25V vs 4.5V to 5.5V for the other speeds. How stable is the power throughout the GQ-3X? Perhaps I should try an external power source? What are the specs for the power adapter?

Sorry for all the questions and thank you, your help is greatly appreciated.
Nic
ZLM Posted - 10/08/2016 : 12:52:33
I think your GQ-3X is able to support this chip.

Your GQ-3X is Re1.00. It is the first releases of firmware. There are some bugs have been fixed after that.
teknix1 Posted - 10/07/2016 : 23:32:26
Thanks for the reply.

I only own two of these devices, they both do the same thing. Most likely they are from the same batch.

Can you confirm that I should be able to program this device with the GQ-3X Re-1.00? I Tried using a newer version of the software and it told me this device was incompatible with my hardware revision.

Nic
ZLM Posted - 10/07/2016 : 22:07:34
think about the chip, try another chip if possible.

The line you added to the device list is working.

MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 1.77 sec. Snitz Forums 2000