MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 Incompatability with DualCore AMD Athlon 64 CPU's?

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List Spell Checker
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File
Check here to include your profile signature.
    

T O P I C    R E V I E W
vk4akp Posted - 11/16/2007 : 22:02:27
Hi, I'd like to hear from anyone who has been having trouble with getting the `True USB Willem programmer' to work with more modern computers.

In my case I am using the following.

M/Board - Gigabyte GA-M56S-S3
GFX Card - Gigabyte GV-NX84G256H
RAM - 2 Gig's, DDR2 800 dual channel.
CPU - Dual Core AMD Athlon 64 4000+
OS - Windows XP Home (32bit)

I have found that the programmer will work on legacy computer equipment (P233MMX laptop) but not on my brand new PC (AMD AM2 64).

I get read write and sync errors between the programmer software and the USB device driver when the program tries to connect.

Often causing the GQ programmer software to lockup and crash.

Sometimes I get Blue Screen of Death and complete OS fail with a reference to the EZusb.sys file as being the cause.

EZusb.sys comes up as Ver 1.30.0000 Year 2001? Perhaps a never version is available somewhere?

I have run stress tests and diagnostic tests on all the hardware. And I have also updated Bios & OS to the latest releases.

I would like to hear from anyone who is able to test the programmer on a similar CPU platform? And what the results were?

I am also available on all IM services as vk4akp and I have voip and phone available to discuss this further with anyone interested.

TNX,
Ken
.-.-.
16   L A T E S T    R E P L I E S    (Newest First)
kinjo214 Posted - 01/16/2017 : 01:29:01
I am Having SYSTEM THREAD EXCEPTION NOT HANDLED problem in my PC.
nysom Posted - 04/08/2008 : 06:59:20
See my reply in this thread...

http://www.mcumall.com/forum/topic.asp?TOPIC_ID=1052
ZLM Posted - 04/07/2008 : 10:22:01
h**p://www.mcumall.com/download/TrueUSBWillem/WIN98SE.zip

Try those files to overwire the driver files installed from the GQ software in the windows driver directory.
Then you may need to reboot the computer if not works after overwrite.

Also, see following link:
http://support.microsoft.com/kb/294292

nysom Posted - 04/06/2008 : 09:43:42
Well, I have not been able to get the ezusb.sys driver to load under windows98se even thought their website states otherwise. Hope they add support for the cyusb driver.
ZLM Posted - 12/06/2007 : 09:39:44
Hi Mathias, Thanks for input on this topic.

What model of your programmer is? And does it work well on any other machine?
MaMe Posted - 12/06/2007 : 03:45:29


Hi there,

I almost got the same machine (CPU - Dual Core AMD Athlon 64 4000+
OS - Windows XP Home (32bit)) and also have the same trouble
(programmer problems and bluescreens with reference to ezusb.sys)

So you are not alone.

How are you trying to fix your problem? I created windows applications to use ezusb.sys. So I would need to rewrite the usb concerning dlls for the new driver (cyusb.sys).

Greetings,

Mathias
mcumall Posted - 12/01/2007 : 10:21:02
Thanks for your information, we will take a look on new driver. If it works, then will replace the current driver.
However, there are no other user report this similar issues so far. We will do a analysis after received the defective programmer board.

vk4akp Posted - 11/28/2007 : 20:03:01
From Cypress.
---

Ken,

The CYUSB driver is a generic driver, and can be used with the AN2131. The OS should not be a problem at all. All you will need to do is get the new API from your old ones using the help files i sent you.

The last buy date for the AN2131 was August '05 and a prune notice was sent out to all customers. The CYUSB driver should be able to solve your issue. Let me know if you have any other questions.

Regards,
Vihang.

---
.-.-.
vk4akp Posted - 11/27/2007 : 06:37:29
Another update.

I have been able to test a second programmer on the same computers and software.

The second programmer will this time at least talk to the software on the newer PC.

While I did still experience the same communication errors etc, be it on a far less regular basis, I was able to read, write, verify, & ID 27c256 & 27c512 eproms.

.-.-.
vk4akp Posted - 11/25/2007 : 00:25:28
The following should help the MCUmall programmers update the software for their device.

Cypress, Manufacturers of the AN2131 IC used on the `True USB Willem Programmer (GQ-3x)' recomend to go away from the problematic EZUSB.sys driver and instead use the CYUSB.sys driver.

Here is a copy of their email to me regarding this.

This information should assist MCUmall in updating their software driver.

--
The new cyusb.sys driver should work for all EZ-USB parts (AN2131, EZ-USB FX, EZ-USB FX2). It is not limited to high-speed devices only. Unfortunately, the CYConsole control panel included with the uStudio download cannot be used to load firmware that renumerates on the full- speed EZ-USB devices (AN2131, FX). The new control panel CYConsole can only interface with the FX2 and the SX2 high speed devices only. CyConsole should work with the AN2131, but you will find that some of the buttons will not work correctly because they are specifically tailored for the FX2.

Please note, that we do have a work around for this. Again, the user interface test utility USB Console does not currently support firmware downloads to the AN2131. To work around this you can configure your device with one VID/PID that you setup to bind to the ezusb.sys driver. The older test utility in the AN2131 kit EZMr Control Panel can then be used to download the firmware you are developing. This firmware should renumerate with a different VID/PID that you have setup to bind to the cyusb.sys driver of the CY4604. You now can close the Control Panel and open CyConsole until you wish to download again. The good thing about this is that you can write your PC application to utilize the API of the CY4604, which is a much cleaner way to interface with the driver.
--
.-.-.
vk4akp Posted - 11/23/2007 : 04:31:21
OK, I've been talking with Cypress (Manufacturers of the AN2131 USB IC used on the `True USB Willem Programmer'.

It seem's that the problems I am having are known issues with the drivers being used on newer hardware and windows XP.

The company also points out that the EZUSB.sys driver is only for development and is not intended for use in a production device.

Instead they recomend a far more stable driver (CYUSB.sys)

As I find out more I will post here.

.-.-.
vk4akp Posted - 11/22/2007 : 07:06:14
The following error message after the BSOD might be of some help in deciphering what the problem is?

*** Stop: 0x0000007E (0x0000005, 0xB52F8548, 0xBACFFAB0, 0xBACFF7AC)
*** EZUSB.SYS - Address B52F8548 Base at B52F7000, Datestamp 3E49AB5E

If anyone has any clues, I'd love to hear some idea's?
.-.-.

`And Remember - Only Amiga Makes it Possible!! ;)'
vk4akp Posted - 11/17/2007 : 16:30:34
Hi, OK Thanks. Thats good info. It would be nice to find another Dual Core user, but still your machine is fairly modern and similar in a lot of ways so its a good start.

When I get home this evening I'll have MCUmall send out another programmer to test.

Thanks for your help.
.-.-.
ZLM Posted - 11/17/2007 : 10:48:20
I am using standard driver which is installed when setup the QG-3X software.

I have both Windows2000 SP4 and WindowsXP SP2 installed.

My CPU is not the Dual core I think. It is AMD Athlon 64 CPU @ 3500+ Mhz, but I think it should not be a factor.
vk4akp Posted - 11/17/2007 : 06:55:37
Hi ZLM, Thats great news. It is still possible I have a faulty unit. But because it works fine on an Old P233MMX I doubt it is faulty. But I guess anything is possible.

Can I have some more details as to what your setup is? What OS you are using? Did you have to use any special USB drivers for the 64bit Dual core CPU? Anything else that might help?

TNX
.-.-.


`And Remember - Only Amiga Makes it Possible!! ;)'
ZLM Posted - 11/16/2007 : 23:58:30
I am using AMD Athlon 64 CPU 3500. And no problem at all.

MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.16 sec. Snitz Forums 2000