MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 PIC Programmer
 USB PIC Programmer ICSP mode

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List Spell Checker
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File
Check here to include your profile signature.
    

T O P I C    R E V I E W
AstroBrewer Posted - 10/30/2008 : 20:56:22

Hello. I have a USB PIC programmer from MCU Mall that I purchased from EBay. It works great for programming PIC16F628A in ZIF socket. No problems reading or writing PIC data. I am trying to make ICSP work. I have connected wires from ICSP header to signals on PIC on my breadboard. PIC programmer software reports that it does not recognize PIC, and when I try to read it reports all 3FFF's in flash. It appears that PIC is running code that was already loaded -- I see activity on PIC I/O ports which shows that it is running the program loaded -- so PIC is not going to programming mode but just powering up via Vcc from ICSP header.

Am I missing some configuration somewhere? I have connected all 6 wires on ICSP header to appropriate PIC pins. Continually pulling and re-installing PIC in my breadboard circuit while debugging program is a little tedious, and I would be much happier if ICSP were working.

Thanks.
5   L A T E S T    R E P L I E S    (Newest First)
ZLM Posted - 11/02/2012 : 08:47:01
Make sure your connections are correct.

If you are sure all connections are good, but it still not work, then directly connect those lins to the ZIF socket instead of ICSP port. That must be working.


Image Insert:

88.91 KB
jglassford Posted - 10/31/2012 : 22:02:03
I too am having problems getting the USB Programmer to work in ICSP mode.

I'm trying to program a 12F629. I can program the chip just fine using the ZIF socket.

I've connected the chip directly to the programmer (there aren't even any other components in the circuit) as shown in this image: the mapping between the USB Programmer and the circuit is shown on the right.

On the left is a screenshot of what the "USB-PIC" program reports (and yes the program is in ICSP mode as shown on the screenshot).

h**p://sphotos-e.ak.fbcdn.net/hphotos-ak-prn1/46179_10152231034180591_15835374_n.jpg

It should be fairly straightforward to get this working but for whatever reason (I'm probably missing something simple) it's not. Any thoughts/suggestions are welcomed!




An unrelated issue, whenever I try to program using the ZIF socket I get the following prompt:

h**p://sphotos-g.ak.fbcdn.net/hphotos-ak-ash3/545363_10152231039615591_1375249432_n.jpg

The program seems to run fun regardless if I say yes or no. It sounds as though there's a problem with the hex code. Is there likely a line in the code that's trying to set the OSCAL value incorrectly or something? I don't actually know much about writing programs for these devices (I'm just loading a program that someone else wrote at the moment) but would like to understand where this warning is coming from.

Again, any insight is greatly appreciated.

Thanks.
ZLM Posted - 11/03/2008 : 21:51:35
I tried on my USB PIC, the ICSP header works on 16F628A and 16F57. I connected 5 of 6 pins. The LOW pin not used.
AstroBrewer Posted - 11/01/2008 : 12:26:46
Yes. I did set programmer to ICSP mode.
ZLM Posted - 10/31/2008 : 13:44:34
Did you switch programmer to ICSP mode?

From software menu, click on Options->ICSP mode.

MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.14 sec. Snitz Forums 2000