MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 Problems writing M27C1024 PLCC44

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List Spell Checker
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File
Check here to include your profile signature.
    

T O P I C    R E V I E W
circuit Posted - 09/21/2009 : 05:23:48
I have tried to program a couple of M27C1024's in PLCC package. Here is a photo of programmer with adapter and a screenshot of newest software:
h**p://img28.imageshack.us/img28/690/78756371.png
h**p://img28.imageshack.us/img28/7545/img3127.jpg

A strange error, because address 0x00 in the file contains values FF that should not be programmed into device.
It reads the chip correctly. I have measured voltages during programing and did not find any problems, all signals are present on the chip. Except one small thing - signal voltages at some pins are only about 3V instead of 5V (A14 for example).

It somehow managed to program up to address 0x400the first time I tried, but then just started showing errors at address 0x00.

I have tried to choose different manufacturers in software, but with no luck.
I would try with different chips, but they are unavailable in my country and I have bought a lot of these ST chips.

What should I do?
29   L A T E S T    R E P L I E S    (Newest First)
ZLM Posted - 05/21/2016 : 07:19:11
check your USB cable and chip.
dav1129 Posted - 05/20/2016 : 19:55:17
Some years back I used a GQ-4X to write files to a M28F102 chip. Some years on I need to do it again. Although my memory is vague, I remember it was to some extent a hit or miss effort.

I am using the correct adapters ADP-055 and ADP-054

This time around here's what I can do: I seem able to erase a chip but must do it many times and preferably it seems sometimes on different speeds. But if only one, then slowest. The chip then tests blank and verifies okay. If it doesn't then I repeat numerous erase passes until I do.

To be sure I can save the chip to a file and check with notepad that it is an erased chip. Vice versa I can write that same saved file back the chip and if properly erased before it will pass blank check and verify.

What I can't seem to do is write a real file. I seem always to stall at 19% regardless of which speed.

Any ideas? Is an external power source perhaps required or as I cannot remember if I used any before, do I need to know file or chip specific parameters when loading a file?

Download Attachment:
131959

Image Insert:

131959 bytes
Parso Posted - 11/08/2012 : 03:13:26
I know its an old thread but I was having similar problems when programming the ST M28F102 PLCC-44. I have the GQ-4X ADP-54 and a few others ADP-17 etc.
I was having some very frustrating issues which turned out to be related to the erasure procedure meaning that that chip was never really erased, simply it wasn't working at the default high speed. I had to drop this all the way down to -2 before it would complete the erase properly. After that everything programs correctly.

From a couple of posts above I use an ADP-17 in the ADP-54 40 pin zif socket as this allows me to extract the IC properly using an extraction tool as I find the bottom right hand PLCC44 socket too close to the 42pin ZIF. On the ADP-55 this would not be an issue and in hindsight I could have bought this alone for my purposes
Hope it assists someone

Cheers

Mark
ZLM Posted - 06/04/2011 : 07:32:32
Can you confrim your chip is blank?

The 27C1024 PLCC44 chip is a OTP(One Time Programmable) chip. It can not be erased.

The 28F102 is flash. Can you get correct ID of 28F102? Did you erase the chip and do blank check before write?
tom_ing Posted - 06/01/2011 : 13:30:44
Hi,

I just updated the GQ-4X sw to version 6.12...an I still have the same issue...when trying to write a PLCC44 27C1024 or 82F102 chip in the ADP-054 adaptor....Write error at "Write failed, Address=0x000000, Buffer=0xFF Device=0x00 (when chip is placed in the lower PLCC44 socket).

When i place the chip in a PLCC44 to 40DIP adaptor and place it in the ADP-054 in the ZIP40 socket...i still can not write a full chip, but programmer stop at "Write failed, Address=0x000205, Buffer=0xFF Device=0x00...and when i read the chip after i can see that it managed to write some information to the chip before failing.

Please note...I have tryed 2 different GQ-4X programmeres and also 2 differetn ADP-054 adaptors...but same result.

Please help me here...

Regards
brchip Posted - 03/11/2011 : 06:28:58
I'm having the same problem, I can't write a M27c1024 PLCC44. I'm using this adapter: h**p://www.sivava.com/buynow.php?pd=B12

The first time I tried it started writing and stopped half way. The second time it stopped right at the beggining, and now it won't even start writing and gives an error, but the chip is still blank.

Please advise.
ZLM Posted - 09/30/2010 : 22:27:17
The adapter should under warranty. Write to support@mcumall.com for the warranty.
tom_ing Posted - 09/30/2010 : 11:27:57
Hi,

Used GQ-4X programmer...

Setting on ADP-054 16 Bit EPROM adaptor v3:
J1 : pin1 and pin2 connected
J2 : all open

9V DC power supply connected..

new PLCC44 ST M27C1024-12C6 placed in the lower PLCC44 socket..

GQ-4X programmer firmware : Re-1.30
GQ USB Universal Eprom Programmer software Re. 5.03B

I select the M27C1024 device in the programmer software...click read -> file read with all FF...then I click blank check -> "chip is blank" info from the software... then i click write -> i get error "Write failed, Address=0x000000, Buffer=0xFF Device=0x00"

I got another programmer GQ-4X programmer...same procedure as described above...same result "Write failed, Address=0x000000, Buffer=0xFF Device=0x00"

Then it can only be adaptor issue...but that is a bit strange since i just bourght it from mcumall.com 3 days ago.

Will you send me a new adaptor?

Regards
ZLM Posted - 09/29/2010 : 17:27:08
The chip is a confirmed/tested chip on GQ-4X. So, if you can confirm your have good settings and pin contctings, then it would be either programmer or adapter problem.
tom_ing Posted - 09/29/2010 : 10:18:23
Hi,

I also have write issues with my GQ-4X programmer...when using ADP-054 16 Bit EPROM adaptor...and I am trying to write a new ST M27C1024 chip.

I can read ok all FF FF FF inside....

But when i blank check and then write i get the error

"Write failed, Address=0x000000, Buffer=0xFF Device=0x00"

I have tryed other new chips same issue....can anyone help?

Regards
ZLM Posted - 01/25/2010 : 10:09:00
Is it possible sent the programmer,adapter and a chip to me for testing?
If the programmer has defective, then we will exchange a tested one for you.

Write email to support@mcumall.com for the RMA and procedure.
circuit Posted - 01/24/2010 : 15:01:14
OK, I have tried it with DIP40<-PLCC44 adapter ("ADP-017") in 40 pin ZIP socket - same result. Also I have tried it with other 16 bit adapter (bought from sivava) - same results in PLCC44 ant ZIF sockets. Tested few chips, same results.. :(
ZLM Posted - 01/23/2010 : 00:10:55
That is strange. This never happened. If you have ADP-017, then you can put the chip in it and then place the ADP-017 into the 40 pin ZIF socket.
This will check if the problem with the PLCC44 socket on 16 bit adapter.
circuit Posted - 01/21/2010 : 04:24:58
Tried it again. After blank chip is inserted, programmer reads it all filled with "FFFFFF". Then I open my BIN file, that starts with a few "FFFFFF" as well. Write process fails at address 0x00 (first byte). After that, chip reads fully filled with "000000". When I re-insert the chip (basically re-connect it's power), the chip reads all "FFFFFF" again.
I have re-checked and all contacts are good.
Have you encountered this problem before?
ZLM Posted - 01/20/2010 : 09:51:33
GQ-4X is a Willem farmily programmer. So, it needs a ADP-055 to program 27C1024 EPROM.
circuit Posted - 01/20/2010 : 04:54:29
I will look into it after a few days.

Also, is it possible to program 27C1024 chips with 40pin DIP package without the adapter? I did not find DIP package in the device lists.
GQ-4Q has 40 pin socket, so I think it should be possible.
ZLM Posted - 01/12/2010 : 08:49:43
Your chip is OTP chip(one time programmable), so, use a used chip to test is the best to save the new chip.

I think there are some pin contacting not well. If it is always fail at 0x400, then check A10 pin of the chip.

If you are 100% sure the pin contacting is good, then please send a sample chip to me, I test it for you.
circuit Posted - 01/12/2010 : 03:31:57
Sorry, I do not have such "rectangular" screwdriver.
tps_star Posted - 01/11/2010 : 22:31:36
thancks circuit
but i need picture from board without case
please take me picture mainboard without case
thancks
circuit Posted - 01/11/2010 : 12:02:50
tps_star, big enough?
imgur.com/xlTxq.jpg
imgur.com/fOCh6.jpg


ZLM, any suggestions how to solve this problem?
tps_star Posted - 01/09/2010 : 07:56:40
hi circuit
is possible take me high resulation picture from your true usb programmer
circuit Posted - 01/09/2010 : 05:17:26
This is the adapter and a chip in it:
imgur.com/gRh0D.jpg

I have also tried a self-made PLCC44-DIP40 adapter, but it also does not work.
ZLM Posted - 01/08/2010 : 15:19:14
Which adapter you used?
circuit Posted - 01/08/2010 : 12:52:13
Hello,

Now I have upgraded to GQ-4X programmer and am trying to program the same chip. I am using most recent public version of software and this adapter (you have recommended it during the purchase of programmer):
mcumall.com/comersus/store/comersus_viewItem.asp?idProduct=4289

And I still have the same problem :( The contacs in PLCC locket are good.
Chips are new and I have tried a few of them. The same chips were successfully programmed with ELNEC MemProg.
ZLM Posted - 09/22/2009 : 12:36:30
I think it may be the adapter problem.

OR check you chip pin contact in PLCC44 socket.

You do not need the address cable connected. Remove that cable and see if it makes different.

Direct PLCC-DIP40 adapter does not work in this case.
circuit Posted - 09/22/2009 : 11:45:12
Unfortunately no luck with that.. Could you recommend any methodology to test signals, etc? I do have digital scope with 16 chan LA..
Does GQ 4x support direct PLCC->DIP40 adapters?
ZLM Posted - 09/21/2009 : 19:40:30
That is fine. Our 16 bit EPROM adaper uses lower socket.

Looks like your adapter missing one capacitor. You may try to add one 10uf.
circuit Posted - 09/21/2009 : 07:37:29
According to markings, the chip is in correct socket:
h**p://img19.imageshack.us/img19/3540/img3129y.jpg

In this socket it reads the chip correctly. I have tried to read it in other socket (tried with both jumper positions), but even a blank chip reads with random F8 and F0..
ZLM Posted - 09/21/2009 : 07:14:14
It seems you place the chip in a wrong socket. Place the chip in another PLCC44 socket and try.


MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.27 sec. Snitz Forums 2000