MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 GQ4X4 verify failed on 27C160- 00 replaced with FF
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jpolo

1 Posts

Posted - 11/12/2020 :  18:20:52  Show Profile  Reply with Quote
I'm trying to program M27C160 EPROMs with the GQ4X4 and ADP-054. The chip seems to program normally (100% complete) but the verify fails with all "00"s in the original file being replaced by "FF"s on the chip. have set the correct voltages in devices.txt and verified there is minimal voltage drop on the USB port, I have also used an external power supply and tried programming at slower speeds. J1 on the ADP-054 is set to 1-2. I have four 27C160s and have the same problem with each. I just programmed several 27C322s with no issues so I don't think there's anything wrong with the hardware.

Here's the line in devices.txt

Name="M27C160",ID="XXXX",Class="27C800",VCC="5V",WVPP="12.7V",WVCC="6.5V",Category="EPROM",MFG="ST",CodeSize="2097152",Adapter="ADP-054 16 BIT EPROM ADAPTER";


Here's the error upon completion:


Here's the original file:


Here's the result of reading the programmed chip:



Any ideas? This is driving me nuts.
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.19 sec. Snitz Forums 2000