MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Programming AM29F040 error
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Dexter

3 Posts

Posted - 08/03/2004 :  13:48:12  Show Profile  Reply with Quote
Hi,
I cannot program any AM29F040 devices. I can get ID, read, erase, and blank check, but not write to chip. I get this error:
Error at 0x000000 Chip = 0xFF buffer = 0x25

I checked Vpp settings at its 12V when checked on (Test H/W tab).

Can someone confirm the other jumper settings? JP5, JP6, JP7?
Reply #1

Dexter

3 Posts

Posted - 08/04/2004 :  02:02:06  Show Profile  Reply with Quote
Oh, I have a standard willem programmer.

I cannot even ID or erase now, no matter which chip I use. (I have 5 29F040 chips).

any ideas?
Go to Top of Page
Reply #2

someone

28 Posts

Posted - 08/05/2004 :  13:24:42  Show Profile  Reply with Quote
Sector protected?
Go to Top of Page
Reply #3

Dexter

3 Posts

Posted - 08/05/2004 :  13:45:24  Show Profile  Reply with Quote
When it did work, it didnt seem sector protected. Shouldnt I be able to at least ID the chip, no matter if its sector protected or not?

thanks!
Go to Top of Page
Reply #4

SBNova

USA
3 Posts

Posted - 09/23/2004 :  15:35:11  Show Profile  Reply with Quote
I have nearly the same problem, with error at 0x000000 chip=0xff buffer=0x00. On the device page I tried selecting "skip write 0xff" with no difference. I have the MCUMall.com board that is the "dual powered" willem programmer, with the USB power source. Chip is an AMD 29F040B C 1993 AMD. I have windows XP on my Compaq laptop.

I also cant erase this same chip (actually I have two of them- both brand new, except I programmed one of them one time with my old programmer) I get "erase completed by check DQ7", but when you re-read it, it still has data.
Go to Top of Page
Reply #5

SBNova

USA
3 Posts

Posted - 09/23/2004 :  15:43:13  Show Profile  Reply with Quote
When looking at the programmer with the zif handle "up", serial to the left, and USB/12v to the right, I have the following settings;

JP-1 empty- no jumper
JP-2 upper position, connecting the top two of the three pins.
J-1 the one to the right of the zif- jumper is on the lower two pins of the five.
J-2, also to the right of the ZIF, is on the upper two of the six pins.
JP-5 the jumper is on the upper two of the three pins.
JP-6 jumper is on the lower two of the three.
JP-7 jumper is on the lower two of the three pins.

This is as correct as I understand via the instructions. The JP-5,6,and 7 dont look like they are important when using USB power- as it says it only has 5v- which is what a 29F040 needs right?
Go to Top of Page
Reply #6

someone

28 Posts

Posted - 09/24/2004 :  15:26:57  Show Profile  Reply with Quote
Check your A18 jumper setting. It located at the left side of DIP.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.31 sec. Snitz Forums 2000