MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Is this 16bit EPROM adapter compatible with Willem
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

almomo1

Spain
10 Posts

Posted - 01/13/2010 :  12:30:53  Show Profile  Reply with Quote
Hi everyone!

I own a Dual Powered Enhanced Willem Programmer which I have been using to program 27C801 EPROMs (from ST Electronics). It worked perfectly.
Now I am trying to program 27C160 (from the same manufacturer) so I bought this adapter on eBay:

htp://img707.imageshack.us/my.php?image=dscn0042d.jpg

htp://img339.imageshack.us/my.php?image=dscn0043i.jpg

(I can't believe I am not allowed to link to photos! They're ABSOLUTELY necesary to explain oneself properly!! Please correct the URL to add a 't' in order to see the photo)

The seller said it would work on Willem programmer, so I got it. It is very easy to plug (the address wires are all together) so I think I'm not connecting anything in the wrong way. I am using the same jumper settings than in 27C801 programming, EXCEPT FOR JP-1 (because there is where the wires are connected to the adapter). I also changed the DIP-switches as the program showed.

According to the datasheets, both 27C801 and 27C160 have the same voltage ratings and the same timing, that's why I use now the same configuration on the program and jumpers than I used with 27C801.

I can read from the EPROM, but can't program: an error appears just after writing the first byte.

What am I doing wrong??
Is that adapter fully compatible??

Thank you very much!!

Edited by - almomo1 on 01/13/2010 12:34:36
Reply #1

almomo1

Spain
10 Posts

Posted - 01/15/2010 :  05:31:47  Show Profile  Reply with Quote
Please, can anybody help me??
Go to Top of Page
Reply #2

ZLM

2920 Posts

Posted - 01/16/2010 :  05:27:41  Show Profile  Reply with Quote
http://www.mcumall.com/forum/topic.asp?TOPIC_ID=309
Go to Top of Page
Reply #3

almomo1

Spain
10 Posts

Posted - 01/16/2010 :  08:32:31  Show Profile  Reply with Quote
Ok, then... My programmer is going to trash right now... I bought it because in the specs claimed it worked with 27C160 and 27C322..............................

Is there any newer version that REALLY supports M27C160 and M27C322?

Thanks!
Go to Top of Page
Reply #4

almomo1

Spain
10 Posts

Posted - 01/17/2010 :  10:16:33  Show Profile  Reply with Quote
quote:
Originally posted by EZoSat

- I do not see jumper left from dipswitch , lower position (Vpp-ZIF32/1)


I tried with it and without it, and never worked. I just took the photo when it wasn't on.

quote:
Originally posted by EZoSat
- Go in Test H/W mode, keep settings as selected for 27C160, adapter installed
Activate 32-Vcc on , measure ZIF42/22 5.7V
Activate 1-Vpp off/on, measure ZIF42/32 5V/12.7(off/on)



I did as you said, but i don't get 5.7V on ZIF42/pin 22; I get 4.9V
On pin 32 I get the right voltage.

I tried right now programming a 27C322 and it ended succesfully (although I got an error when veryfing, but it was my fault :D).
Maybe it could be an EPROM issue... I tested 2 27C160 and both were faulty... I'll try again...

Thanks!
Go to Top of Page
Reply #5

almomo1

Spain
10 Posts

Posted - 01/17/2010 :  13:38:12  Show Profile  Reply with Quote
quote:
Originally posted by EZoSat

For eproms apply external power supply only .
Check Vcc settings jumpers.


Ok, I'll try with external power supply... what voltage and polarity are needed?

quote:
Do you erase (UV lamp) chips before write ? Verify with Blank check.

They were blanked when I bought them, but I erased myself again anyway.

I tried 2 more 27C160 and none worked. But all three 27C322 I programmed worked properly... how strange...
Go to Top of Page
Reply #6

almomo1

Spain
10 Posts

Posted - 01/19/2010 :  12:42:05  Show Profile  Reply with Quote
quote:
Originally posted by EZoSat

quote:
what voltage and polarity are needed?

+9..12V


Ok thanks :D
I also need the polarity... Maybe is +(o- (i.e., positive outside and negarive inside the connector)


quote:
Run Blank Check before programming.


I did, and they were blanked.

I hope tomorrow I will try using my AC-DC power adapter... I'll post whatever result I get.

Edited by - almomo1 on 01/19/2010 12:43:41
Go to Top of Page
Reply #7

almomo1

Spain
10 Posts

Posted - 01/20/2010 :  11:07:15  Show Profile  Reply with Quote
I tried again now using the power adapter, but no luck!! It supplies 12 V and 1A, but the problem is the same...

There is some strange behavior: when programming 27C801 and 27C322, Vcc and Vpp LEDs are lighted up, but not when selecting 27C160 on the application: both turned off when I select 27C160... maybe the DIP switch configuration is not the right one for that EPROM? I tested Vcc and Vpp on ZIF42 pins and there were the proper values, and the LEDs turned on when selected the respective checks on "HW Test" tab.

I even tried to program 27C160 as if it was 27C322... although the process ended succesfully, when I read back the EEPROM, it was empty...

Any idea?

Edited by - almomo1 on 01/20/2010 11:08:00
Go to Top of Page
Reply #8

almomo1

Spain
10 Posts

Posted - 01/22/2010 :  13:18:15  Show Profile  Reply with Quote
Well, I tried again changing switches number 6 and 7 on each position, but no luck... there is no way that damn EPROM can be programmed...

I'll study the schematics for learning what the function of each DIP-switch is... I can't guess why it doesn't work but the voltage is the proper one on each ZIF42 adapter's pin.

Thanks for all, EZoSat... If it weren't for you, I would have given up some weeks ago...
Go to Top of Page
Reply #9

simeon

United Kingdom
79 Posts

Posted - 01/23/2010 :  06:41:13  Show Profile  Reply with Quote
there is a jumper on the right says vcc 5v or 5.6v
if you take off the adpater
simply take it off and dock it on the center pin
this is a real no brainer

for VCC=6250 eprom programming level

27C160 (TA = 25 C; programming VCC = 6.25V 0.25V; VPP = 12.5V 0.25V) h**p://doc.chipfind.ru/stmicroelectronics/27c160.htm
datasheet


im surprised you managed to flash any!!

this appears to be a common unknown

also place the eproms in the freezer in a freezer bag on conductive foam for ten mins to chill them
then they take a better cell charge onboard

watch out for windows printer spoolers and drivers some dont like the programmer and spool its output leading to time errors

use normal or epp only not ecp
some bios allow you to turn off lpt interrupt set to enabled

set the two speeds to 140ns top and 40ns lower

140us = 140ns speed program them a little slower than there top speed forinstance
200ns types wont like being flashed at 140us so set it to 220ns
and the lower setting would be 220/4 = 55us

machine toshiba equium laptop usb only type
p5b asus main machine
thinking of adding dual lpt pci card
both used for top and lpt via usb where i can

old p2 programming grumbling tank with xp sp3 for true serial and lpt

all machines bios set to enable bios plug and play aware o/s and lpt spollers services and drivers removed
legacy detection enabled

Edited by - simeon on 01/23/2010 06:56:08
Go to Top of Page
Reply #10

almomo1

Spain
10 Posts

Posted - 02/07/2010 :  02:21:12  Show Profile  Reply with Quote
Still no luck... I removed the JP7 jumper to set programming voltage to 6.25 but still the same error message... and also used an external power supply and put the EPROM on the freezer, but the same result:

"ERROR at 0x000000 Chip = 0xFF Buffer = 0x4C" (it appears less than 1 second after I push the "Program chip" button)


I think there is indeed a bug on the software that doesn't allow to program 27C160...

Edited by - almomo1 on 02/07/2010 02:23:48
Go to Top of Page
Reply #11

ZLM

2920 Posts

Posted - 02/09/2010 :  23:34:49  Show Profile  Reply with Quote
Can you confirm your programmer are working good?
If so, then the adapter may be something wrong.
Go to Top of Page
Reply #12

almomo1

Spain
10 Posts

Posted - 02/10/2010 :  06:05:23  Show Profile  Reply with Quote
Yes, I programmed 10 27C801s and 4 27C322s, and all worked...
I used the same adapter to program 27C322, so maybe it has something wrong, but it worked so far...


quote:
Originally posted by ZLM

Can you confirm your programmer are working good?
If so, then the adapter may be something wrong.



You directed me in your first post to a thread where you said:

quote:
your PCB3B does not work well on M27C800, M27C160 and M27C322. This is common issue on all PCB3B.


...so maybe that's the problem: I have a PCB3B, so 27C160 won't work despite of the adapter, will it?

Edited by - almomo1 on 02/10/2010 06:09:50
Go to Top of Page
Reply #13

ZLM

2920 Posts

Posted - 02/10/2010 :  18:06:48  Show Profile  Reply with Quote
Some PCB3B does not work well on 27C160 with unknown reason.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.14 sec. Snitz Forums 2000