MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Willem enhanced PLEASE HELP !!!
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

tomaz

Yugoslavia
1 Posts

Posted - 04/14/2006 :  02:52:12  Show Profile  Reply with Quote
Hi!

I have a Enhanced Willem Universal EPROM Programmer, and this is crashed. From my modesty experience I suspect on 20 pin chip the only one in the programmer and 14 pin chip on left side of 20 pin chip. I believe that they are bad because when programmer is on

They are wery, wery hot and programmer canít recognize chip to program. Programmer worked perfectly until power supply didnít burned my motherboard and thru USB my programmer. It is so difficult to me to buy the other one in my country, there for my friend from America helped me once, I canít ask him again.

So, I ask you nicely, please, help me.

Thank you in advance.

Tomaz!

Reply #1

ZLM

2920 Posts

Posted - 04/24/2006 :  01:25:30  Show Profile  Reply with Quote
Hot does not means it been damaged. May be some other components damaged and caused this chip over current. That 20 pin chip is the PAL chip, and it used more current than others chip. Do more testing and to confirm.

Edited by - ZLM on 04/24/2006 01:26:03
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.09 sec. Snitz Forums 2000