MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 PM25LV010 incorrectly ID-d
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

khaahk

22 Posts

Posted - 02/16/2013 :  06:36:08  Show Profile  Reply with Quote
Hi!
This might be a software bug:
SETUP:
PM25LV010 - adapter ADP-004 - GQ-4X software 6.21 - Windows xp pro 32b

If i select the correct chip (that is PM25LV010) then the chip gets id-d as FFFFFF
Image Insert:

32.12 KB



If i select the W25X10 chip, then the PM25LV010 gets id-d correctly.
(7F9D7C)
The program reads it correctly also - but says the id does not match.

Image Insert:

33.54 KB
Reply #1

ZLM

2923 Posts

Posted - 02/17/2013 :  22:49:13  Show Profile  Reply with Quote
Can you ignore the ID warrning and try to read/write the chip?
Go to Top of Page
Reply #2

Naughty

India
35 Posts

Posted - 02/25/2013 :  07:46:18  Show Profile  Reply with Quote
i am having the same Problum & i buy my new GQ-4x Programmer a few Days Ago....is there a solution for it or i can just ignore the ID Check Warning for now ?

Do Searching before Asking, But Asking will never kill you......
Go to Top of Page
Reply #3

ZLM

2923 Posts

Posted - 02/26/2013 :  10:00:44  Show Profile  Reply with Quote
I think your software is not latest. Download the latest sftware and see if the ID correct.
Go to Top of Page
Reply #4

khaahk

22 Posts

Posted - 02/28/2013 :  02:12:45  Show Profile  Reply with Quote
Even if chip gets ID-d as FFFFFF, it still reads, erases and writes ok. Tried software 6.16 and 6.21, two different computers. Both XP though.
Go to Top of Page
Reply #5

ZLM

2923 Posts

Posted - 02/28/2013 :  21:43:07  Show Profile  Reply with Quote
I think there is a software bug on this chip ID procedure.
Go to Top of Page
Reply #6

sadpony

1 Posts

Posted - 02/08/2019 :  10:01:48  Show Profile  Reply with Quote
To fix:

edit c:\Program Files (x86)\ GQ USB Programmer\devices.txt

Search for: PM25LV010

Then in the line with PM25LV010, replace Class="AT25FS010" with Class="W25X10"

Save and done! Should ID correctly now.
Go to Top of Page
Reply #7

anniel

1996 Posts

Posted - 02/08/2019 :  10:47:04  Show Profile  Reply with Quote
quote:
Originally posted by sadpony

To fix:

edit c:\Program Files (x86)\ GQ USB Programmer\devices.txt

Search for: PM25LV010

Then in the line with PM25LV010, replace Class="AT25FS010" with Class="W25X10"

Save and done! Should ID correctly now.


Good advice but kind of late. Is the bug still present in the latest versions?
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.2 sec. Snitz Forums 2000