MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Help Programming AT29C010A
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

ian8115

4 Posts

Posted - 03/29/2007 :  08:12:57  Show Profile  Reply with Quote
Hi. I have recently purchased a Willem Programmer running 0.97ja. I am trying to program an AT29C010A. I have a 5V USB power source and is connected to my Printer port on my Laptop running XP.

I have connected pin 3 to 31.

It will read, verify, and blank check ok but cannot get it to program.

It says Error: Write Sector 0

What I did do by accdent was read then immediately write then it worked but that was just rewriting back to the chip.

I cannot get the 128k File (for car tuning) to the chip. Any help would be much appreciated.

Thanks, Ian
Reply #1

ZLM

2926 Posts

Posted - 03/30/2007 :  07:59:46  Show Profile  Reply with Quote
What is the "I have connected pin 3 to 31."??
You should be able to get correct ID. Did you??
Go to Top of Page
Reply #2

ian8115

4 Posts

Posted - 03/30/2007 :  09:31:36  Show Profile  Reply with Quote
Problem solved! The chip wont write if the chip is pushed all the way in to the PLCC sucket. If I push it in a little bit it writes fine. Must be dodgey plcc adaptor.

My next question, Is the 27C1001 same as 29c010? Thanks
Go to Top of Page
Reply #3

ZLM

2926 Posts

Posted - 03/31/2007 :  00:55:35  Show Profile  Reply with Quote
No. Those are different chips.
Go to Top of Page
Reply #4

ian8115

4 Posts

Posted - 03/31/2007 :  08:41:24  Show Profile  Reply with Quote
That explains alot. It was to replace a 27c1001 in an ECU. How about the 29f010? Thanks
Go to Top of Page
Reply #5

ZLM

2926 Posts

Posted - 04/01/2007 :  14:55:49  Show Profile  Reply with Quote
Depend on your ECU circuit, there is high possibility to replace 27c1001 by 29f010 or 29c010. On pin 31 of chip, it must stay on 5V for 29F010/29c010. But 27c1001 does not care this pin.
The 29c010 has same requirement too.
Go to Top of Page
Reply #6

ian8115

4 Posts

Posted - 04/02/2007 :  10:05:06  Show Profile  Reply with Quote
Oh i see. They were originally 27C1001. What would you recommend? Thanks
Go to Top of Page
Reply #7

ZLM

2926 Posts

Posted - 04/02/2007 :  20:46:39  Show Profile  Reply with Quote
Check original 27C1001 circuit and see if the pin 31 connected to somewhare. If that pin is not connected to anywhere, just short the pin 31 to 32 on 29F010/29c010.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.62 sec. Snitz Forums 2000