MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Automobile engine ECU, Immo, Air bag chip tunning
 93lc66a
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

RedPat

Canada
8 Posts

Posted - 09/03/2010 :  05:26:17  Show Profile  Reply with Quote
Hi,
I need some help to read this eeprom. Every time I read it, he never give me the same result.
The first time I have plug it to my gq4x, I plug it as a normal chip. But now I know is an reversed pin. Is you think I have "burned" the chip?
I want to know wich pin to plug and where. If someone can help, it will greately apreciated.
Thank you!
RedPat
Reply #1

ZLM

2928 Posts

Posted - 09/03/2010 :  07:08:04  Show Profile  Reply with Quote
The software indicated how to place the chip on the programmer ZIF.
There is a pin one marking(dot) on the chip and it should face to left-top.

also, clean up the pin and use a slow speed.

Image Insert:

3.16 KB
Go to Top of Page
Reply #2

RedPat

Canada
8 Posts

Posted - 09/03/2010 :  07:31:08  Show Profile  Reply with Quote
Allo!
I have the 93lc66A version. surface mount



Image Insert:

11.41 KB


Is I have to switch the pin?

pin1 to pin3
pin2 to 4
ect...

For now, I'm shorting my wire.

Thank you

Edited by - RedPat on 09/03/2010 07:43:29
Go to Top of Page
Reply #3

RedPat

Canada
8 Posts

Posted - 09/03/2010 :  08:52:26  Show Profile  Reply with Quote
HI!
Resolved!!!!
No need to reverse pinout!
Good bin now!
Go to Top of Page
Reply #4

cklair

3 Posts

Posted - 11/13/2010 :  06:05:20  Show Profile  Reply with Quote
i have same problem reading rl66(93c66) i cant read it in circut i took it out read it now i try to write back it wont when i varyfy it fails i tried anther chip same part number read it out but will fail varify i have tried reading it 8 and 16 bit none work
Go to Top of Page
Reply #5

ZLM

2928 Posts

Posted - 11/13/2010 :  21:37:49  Show Profile  Reply with Quote
Use lower speed and try to read and write again.

Make sure the pin 1 orientation and pin contacting are no problem.
Go to Top of Page
Reply #6

cklair

3 Posts

Posted - 11/14/2010 :  14:57:39  Show Profile  Reply with Quote
i tried reading it out side ,try to put in cleared file then again wont veryfy.then my frien tried with xprog m every thing went ok. i think something wrong with gx4 programmer it happend twice.low speed didnot help.cool thing in xprog m it will tell you if connectin n one or more pins are not esteblesh properly .this featur is missing in mcu mall programers.
Go to Top of Page
Reply #7

PierreTheron

South Africa
2 Posts

Posted - 04/10/2011 :  08:37:33  Show Profile  Reply with Quote
Hi

Also have this problem with ST93c66 eeprom microwire.

GQ-4x never does a good read or write on these.
i use other programmer to read and write to this chip.

Can this issue be adressed with the next update please?

Thanks

Pierre

Wild thing
Go to Top of Page
Reply #8

ZLM

2928 Posts

Posted - 04/10/2011 :  18:44:23  Show Profile  Reply with Quote
Try Re6.12 sodtware. It fixes 93C66 bug.
http://www.mcumall.com/download/TrueUSBWillem/GQUSBPrgRe6.12.exe
Go to Top of Page
Reply #9

PierreTheron

South Africa
2 Posts

Posted - 04/25/2011 :  21:19:17  Show Profile  Reply with Quote
Hi
Zlm I will test it and report back..

Wild thing
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.23 sec. Snitz Forums 2000