MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Low voltage on address pins
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

overture

2 Posts

Posted - 01/18/2005 :  00:53:03  Show Profile  Reply with Quote
I have bought the enhanced version from e-bay and I could write and verify on AT89S52 but I couldn't program 16F84A or 16F876A. Checking the voltage in HW test setup I found the following voltage in address pins. (VPP is 12.10v)

ZIF Pin # ID Volts
2 A16 5.06
3 A15 3.59
4 A12 5.06
5 A7 5.07
6 A6 5.07
7 A5 5.07
8 A4 5.07
9 A3 5.07
10 A2 5.07
11 A1 5.07
12 A0 5.07
23 A10 5.05
25 A11 3.64
26 A9 3.60
27 A8 5.06
28 A13 4.55
29 A14 5.06
30 A17 3.60
31 A18 4.09

Address 11, 9, 17 and 15 is obviously low. According to willem.org site Address 9 has reason to be low. But I have no idea how to fix the other voltages. There is no schematic and there is no part number on the board. Can anyone please help me on figuring out what can be the possible reason for the problem and how to fix it?
Reply #1

overture

2 Posts

Posted - 01/18/2005 :  13:27:42  Show Profile  Reply with Quote
Problem solved. I was doing a mistake by inserting the PIC in the ZIF socket whereas it should have been inserted in one of the DIP sockets. Everything works fine now.
Go to Top of Page
Reply #2

usb

138 Posts

Posted - 01/22/2005 :  00:12:08  Show Profile  Reply with Quote
All voltages are correct. As long as it higher than 2.4V TTL standard level.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.16 sec. Snitz Forums 2000