MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 Cannot write to ST M35080 / ST 0DODOWQ !
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jc179

25 Posts

Posted - 10/08/2014 :  06:08:23  Show Profile  Reply with Quote
Hi

I am trying to use GQ-4X to write to ST M35080 / ST 0DODOWQ, but so far have had no luck. I've tried both the chips from UK and cheap versions from HK, to no avail. I am able to read them OK, but when I try to write any data and read back the contents of the chip, it is all 00 00 00 ...

Is the GQ-4X not capable of writing any of these chips? The program lists M35080 - what's wrong ?

Thanks,

Jonathan

Edited by - jc179 on 10/08/2014 06:08:42
Reply #1

ZLM

2923 Posts

Posted - 10/08/2014 :  08:43:54  Show Profile  Reply with Quote
This chip is support on GQ-4X. If you can confirm the chip reading i OK,, then the write should work. Try slower speed.
Go to Top of Page
Reply #2

jc179

25 Posts

Posted - 10/09/2014 :  07:56:48  Show Profile  Reply with Quote
Hi ZLM

I've tried my programmer and a friends, both at speed -2 , -1 and 0, different chips too - any other suggestion? Using the ADP088? Adapter pinout I am using is http://www.mcumall.com/support/ADP-088_Connection.html - notice SOIC 5 is "no connection" - is there something different required for writing to it?

Do you have a newer firmware for GQ-4X I can try to see if it helps?? I can send you of the chips as well? Just would like to see this get fixed, There seems to be a lot of folks having problem to write to the chip.
Go to Top of Page
Reply #3

medln25

Morocco
7 Posts

Posted - 10/10/2014 :  00:08:22  Show Profile  Reply with Quote
the top bytes of this chip cannot accept lower values than what it contains. a used chip cannot be reprogrammed if some bytes contains values higher than what you want to write on them.
you have to use a new empty chip
Go to Top of Page
Reply #4

jc179

25 Posts

Posted - 10/12/2014 :  17:34:13  Show Profile  Reply with Quote
Thanks but I am using brand new chips. While this maybe true I am trying to write different values past the incremental write section only.

So my problem is actually on a "new" chip I cannot write AT all. Upon verification or read back, it is all 00 00 00 , even as mentioned past the incremental only section.

Suspect an issue with the programmer its self.
Go to Top of Page
Reply #5

medln25

Morocco
7 Posts

Posted - 10/13/2014 :  01:58:26  Show Profile  Reply with Quote
check the W pin (3) is connected correctly, try to check continuity from the chip pin to the programmer zif socket.
pin 5 is not used by the chip.
how do you know the new chip is read correctly at first place?

Edited by - medln25 on 10/13/2014 02:04:57
Go to Top of Page
Reply #6

jc179

25 Posts

Posted - 10/14/2014 :  06:37:33  Show Profile  Reply with Quote
thanks for the suggestion - I will check that continuity from chip to Gq4x socket.

I know the new chip is reading correctly:
- use same test clip to read existing / new chips (remember: existing chips I can read OK)
- query chip on device "read memory" function shows blank data (for 'new' chips).

Is very evident data is not being written to the chip. A poor connection on the enable write pin is a very good point to investigate.

Will report back, thank you.

edit: corrected wording

Edited by - jc179 on 10/14/2014 07:08:46
Go to Top of Page
Reply #7

jc179

25 Posts

Posted - 10/15/2014 :  19:31:46  Show Profile  Reply with Quote
Hi Medln25

I confirmed that pin3, is connected good to ZIF socket in programmer. Also can confirm I see 3.3v here, and when programming(write) starts it drops to 0v for a moment, then back to 3.3v.

Don't really know what else is wrong:
- All connections verified per ADP088 adapter
- Can read IC ok
- Cannot write - goes through actions, but upon verification / read back it is all 0 - I mean blank (FF's).
- * alot * of posts here with others having same problem writing to the chip... including the other post you respond in.

Would like to help to fix this....I can capture the databus of the programming and verification fail after with logic analyzer if its fast enough to capture it. Maybe will be useful to troubleshoot?
Go to Top of Page
Reply #8

medln25

Morocco
7 Posts

Posted - 10/16/2014 :  14:44:24  Show Profile  Reply with Quote
1. if you have a blank chip read it using your programmer and save the content to file A.bin
2. erase the chip, then read the chip again and save to B.bin
3. make a copy of B.bin, lets say C.bin. open it with a hex editor of your choice and replace all bytes with '11' save it then upload it to the chip. read the chip again and save the content to D.bin
upload the files A.bin B.bin and D.bin so I can take a look to them
Go to Top of Page
Reply #9

Nishka

Canada
3 Posts

Posted - 10/20/2014 :  08:14:42  Show Profile  Reply with Quote
Let me know how this works for you... I have the same problem and its pretty frustrating

Toast
Go to Top of Page
Reply #10

jc179

25 Posts

Posted - 10/20/2014 :  15:20:39  Show Profile  Reply with Quote
Hi

So when attempting to follow the above outlined procedure, USBPrg report the chip doesn't support 'erase function' (see screen shot below). In either case I proceeded with:
- reading a blank file from the chip (file A)
- ran erase function, read it back (file B)
- change file I read from "B" to all 1's
- upload it to the chip, and reading it back (file D).

I also tried function "verify blank" which reports chip is blank, a few times to be sure. Have also verify all connections from chip back to programmer ZIF socket are correct for ADP-088.


I attached the screen shots, and the chip reads.

Download Attachment: m35080-reads.zip
107.43 KB


Image Insert:

24.79 KB

Image Insert:

84.2 KB


Image Insert:

39.75 KB

Thank you for the help

Nishka and all, I'm sure this will work very soon!

Jonathan

Edited by - jc179 on 10/20/2014 15:23:39
Go to Top of Page
Reply #11

jc179

25 Posts

Posted - 10/29/2014 :  19:55:07  Show Profile  Reply with Quote
ZLM, any idea? This chip isn't working??!!!! So many posts on this form about this, can I help to get it fixed??
Go to Top of Page
Reply #12

medln25

Morocco
7 Posts

Posted - 10/30/2014 :  07:45:54  Show Profile  Reply with Quote
the chip does not read correctly, a blank chip should have all incremental bits sets to 00 from factory (not FF).
Go to Top of Page
Reply #13

ZLM

2923 Posts

Posted - 10/30/2014 :  09:07:36  Show Profile  Reply with Quote
I am waiting for the testing chip. It is on the way. I will get it in a few days.

I will update here once I tested it.

Go to Top of Page
Reply #14

jc179

25 Posts

Posted - 11/01/2014 :  21:32:59  Show Profile  Reply with Quote
Chip I have read is reading correctly - How : Known good data is visible in dump file (not corrupt) - Verify by Program code and version are as expected and matching sticker value, so the read is 100%.

I can provide a test chip and binary dump if needed.

thanks all!
Go to Top of Page
Reply #15

jc179

25 Posts

Posted - 11/12/2014 :  16:42:50  Show Profile  Reply with Quote
Hi

Any luck? I can send you a test chip too if needed.

thanks,
Jonathan
Go to Top of Page
Reply #16

jc179

25 Posts

Posted - 12/18/2014 :  21:54:24  Show Profile  Reply with Quote
Hi ZLM

I borrowed a friends programmer, for M35080, it is able to program these chips OK. Is there any firmware update available to fix the issue with the GQ 4x and M35080 ?

Known working:


Image Insert:

53.17 KB

Edited by - jc179 on 12/18/2014 21:56:33
Go to Top of Page
Reply #17

ZLM

2923 Posts

Posted - 12/22/2014 :  19:51:10  Show Profile  Reply with Quote
Yes. I am sure it can be written. I already got the testing chip.

I will let you know in a few days.
Go to Top of Page
Reply #18

jc179

25 Posts

Posted - 12/22/2014 :  20:37:59  Show Profile  Reply with Quote
Thank you! Let me know if there's anything I can do to help...

Jonathan
Go to Top of Page
Reply #19

carpin

Netherlands
4 Posts

Posted - 12/24/2014 :  21:24:22  Show Profile  Reply with Quote
Thank you ZLM
Go to Top of Page
Reply #20

Nishka

Canada
3 Posts

Posted - 01/04/2015 :  10:10:33  Show Profile  Reply with Quote
Hi,
I'm pretty much waiting for the same information. Is there any news or progress? I'd really like to be able to fix the chips I have sitting on the bench
THX

Toast
Go to Top of Page
Reply #21

ZLM

2923 Posts

Posted - 01/09/2015 :  09:00:51  Show Profile  Reply with Quote
I tested with GQ-4X. And found the software has bug on this chip. This can be fixed.
I will do more on this. For sure it can be fixed.
Currently I am busy on another project.
Go to Top of Page
Reply #22

carpin

Netherlands
4 Posts

Posted - 01/11/2015 :  11:50:58  Show Profile  Reply with Quote
Thanks ZLM


Go to Top of Page
Reply #23

ZLM

2923 Posts

Posted - 01/12/2015 :  16:36:55  Show Profile  Reply with Quote
Got chance and tested the chip again.

Found there are multiple version of M35080 chips:

1. M35080 6 (adapter ADP-004 on GQ-4X tested and working good)
2. M35080 3 (adapter ADP-004 on GQ-4X tested and working good)
3. M35080 V6 (adapter ADP-088 on GQ-4X not tested yet)
4. M35080 VP (adapter ADP-088 on GQ-4X not tested yet)

The testing chips I have are M35080 6. For those M35080 6 and M35080 3, the current software works fine with no pin remapping, the ADP-004 is good. That means if your chip is in DIP package, then you can just put it on ZIF. If your chip is in SOIC8, then you do need adapter ADP-004.

For those M35080 V6 and M35080 VP, you need to use ADP-088 based on the message in software after you selected the M35080 chip.

I will order some M35080 V6 and M35080 VP for doing more testing.

Check your chip exact part number.
Go to Top of Page
Reply #24

carpin

Netherlands
4 Posts

Posted - 01/13/2015 :  19:58:01  Show Profile  Reply with Quote
The VP and V6 series are used in car dashboards.

Thanks ZLM
Go to Top of Page
Reply #25

jc179

25 Posts

Posted - 02/09/2015 :  07:03:58  Show Profile  Reply with Quote
ZLM,

These are the SOIC8, V6 / VP - I can even send you a few for testing if needed.

Let me know.

Jonathan
Go to Top of Page
Reply #26

ZLM

2923 Posts

Posted - 02/11/2015 :  17:10:45  Show Profile  Reply with Quote
Thanks. I ordered some VP version on the way.
Go to Top of Page
Reply #27

jc179

25 Posts

Posted - 02/12/2015 :  08:48:29  Show Profile  Reply with Quote
How about a V6 version? Do you want one?
Go to Top of Page
Reply #28

Nishka

Canada
3 Posts

Posted - 02/27/2015 :  12:04:45  Show Profile  Reply with Quote
As we pass a couple more weeks... any news? Do you need a chip, I or any of can send you one.....

Toast
Go to Top of Page
Reply #29

ZLM

2923 Posts

Posted - 03/02/2015 :  11:42:07  Show Profile  Reply with Quote
I got a few 35080 V6 chips from China. However, all of them works same as 35080 6 and working good on GQ-4X. I am wondering if those chips are fake chips(remarked from M35080 6) . Because I expected the M35080 V6 is different to M35080 6. In my impression, those two chips pinout are not same.

Do you know if this is a correct chip?

Works good on GQ-4X, same as 35080 6 version:

15.1 KB


Go to Top of Page
Reply #30

ZLM

2923 Posts

Posted - 03/03/2015 :  11:23:39  Show Profile  Reply with Quote
I order a few 35080VP now, itis on the way. see:



Image Insert:

7.44 KB
Go to Top of Page
Reply #31

ZLM

2923 Posts

Posted - 03/17/2015 :  12:03:58  Show Profile  Reply with Quote
I ordered above item and got it a few weeks later.
See picture.


M35080 VP:

20.61 KB


Tested on GQ-4X and it works well as all other version M35080.

So far I have tested four version chips on GQ-4X:

1. 35080 3
2. 35080 6
3. 35080 V6
4. 35080 VP


All works same way on GQ-4X. No differences.
Go to Top of Page
Reply #32

jc179

25 Posts

Posted - 03/26/2015 :  05:38:45  Show Profile  Reply with Quote
ZLM

First thanks for taking the time to look into this. I have ordered a variety of chip from UK, and HK to try and avoid the possibility of getting a 'fake' chip. At this point I am at such a loss why its not working (read = ok, write = nothing). I would like to ship you 1-2 of the chips I have to see if you have the same result. Can you please contact me offline with how I can proceed with that.

Regarding "M35080 V6 is different to M35080 6" - Did both of these work, even though you consider both to be different chips?

I will post a clear picture of mine tonight.

Again, really appreciate your looking into this, but I really also want to put this to bed.

...I am not sure why so many of us having issues writing to these chips, and its testing OK for you. There are at least 4 other posts of people having issues with these chips. Its either fake chips [But how then could other programmer write to it??], or an issue with the programmer and certain version of the chips.

Thanks

Jonathan

Edited by - jc179 on 03/26/2015 05:42:24
Go to Top of Page
Reply #33

ZLM

2923 Posts

Posted - 03/26/2015 :  09:27:19  Show Profile  Reply with Quote
Please write email to support@mcumall.com, so that I can reply you from from there.

Based on my testing, the M35080 chips are not special chip. The GQ-4X should easily read and write. I did not find any difficulty during my testing.

But there were some confusions. Some documents indicate the M35080 VP and M35080 V6 has different pin layout. But I did not find anything different between M35080 3 and M35080 6.

I got all different version chips and tested, all passed the testing using same pin layout.

Go to Top of Page
Reply #34

jc179

25 Posts

Posted - 03/26/2015 :  17:17:47  Show Profile  Reply with Quote
Hi ZLM

Many thanks. This actually caught my eye, you mention it twice "Some documents indicate the M35080 VP and M35080 V6 has different pin layout" - What is the difference? I wonder if mine are somehow needing that different connection, as the one I am trying is M35080 VP and the 08ODOWQ , which perhaps are slightly different?

Will write you shortly.

thanks

Jonathan
Go to Top of Page
Reply #35

ZLM

2923 Posts

Posted - 03/29/2015 :  19:40:41  Show Profile  Reply with Quote
I do not have 08ODOWQ datasheet. I have M35080 datasheet and it shows a special pinout. However, all chips I have are regular pinout and working good on my GQ-4X.


Image Insert:

35.51 KB
Go to Top of Page
Reply #36

jc179

25 Posts

Posted - 05/19/2015 :  20:30:44  Show Profile  Reply with Quote
Hi

Just a follow up, this is now working with M35080 VP and 0DODOWQ chips. To use upgrade to latest GQ 4x 6.36 software, using pinout as described here:
http://www.mcumall.com/support/_ADP-088_Connection.html

Jonathan
Go to Top of Page
Reply #37

ZLM

2923 Posts

Posted - 03/02/2016 :  22:19:18  Show Profile  Reply with Quote
The latest software Re 7.07 or later version on GQ-4x4 does not need the ADP-088 remapping the connection. The ADP-004 is good enough.
Go to Top of Page
Reply #38

vibroverbus

USA
7 Posts

Posted - 04/26/2018 :  04:22:57  Show Profile  Reply with Quote
Reposting in this thread as well as another because it comes up in google first on many M35080 searches:

I've discovered at least one fact that is the source of many of the complaints about these chips, that seems inadequately / inaccurately documented:

Chips that are labeled as M38050-6 that are used in BMW instrument clusters (as well as probably some other makes and modules I am guessing...), do not use the standard ADP-004 pinout.

They very definitely absolutely use the 'special' pinout aka the ADP-088 pinout.

So for those of us with the GQ-4x or older programmers, and trying to read those specific chips, the doc is incorrect. USE THE ADP-088 CONNECTION for reading those old BMW-cluster chips.

Now, whether there are different M38050-6 chips that use the old 'standard' / ADP-004 pinout, I don't know. Could be, and it could be the BMW chips were silkscreened as -6 when they are really -V6 or whatever. But I guarantee that if you are trying to read those (and those are generally any BMW cluster chip from the early 2000's...), you need to use the ADP-088 pinout remapping, and ignore the posts and threads on this board that say the M38050-6 can use the ADP-004. That is not correct for BMW-cluster chips at the very least.
Go to Top of Page
Reply #39

vibroverbus

USA
7 Posts

Posted - 04/26/2018 :  04:31:12  Show Profile  Reply with Quote
By the way I will add (since this thread deals with not being able to write brand new chips that read as all "00") I am still seeing this problem with the brand new V6 chips I have. Either programming voltage is too low, or there is a programming error, or, the chips are flawed or counterfeit or something. I've been told to go use a dedicated M35080 programmer but I really like my GQ honestly and seems like it should be able to work, unless its' purely a hardware / voltage problem (or the chips are truly bad..)

Edited by - vibroverbus on 04/26/2018 09:18:20
Go to Top of Page
Reply #40

anniel

1996 Posts

Posted - 04/26/2018 :  14:58:48  Show Profile  Reply with Quote
quote:
Originally posted by vibroverbus

Reposting in this thread as well as another because it comes up in google first on many M35080 searches:

I've discovered at least one fact that is the source of many of the complaints about these chips, that seems inadequately / inaccurately documented:

Chips that are labeled as M38050-6 that are used in BMW instrument clusters (as well as probably some other makes and modules I am guessing...), do not use the standard ADP-004 pinout.

They very definitely absolutely use the 'special' pinout aka the ADP-088 pinout.

So for those of us with the GQ-4x or older programmers, and trying to read those specific chips, the doc is incorrect. USE THE ADP-088 CONNECTION for reading those old BMW-cluster chips.

Now, whether there are different M38050-6 chips that use the old 'standard' / ADP-004 pinout, I don't know. Could be, and it could be the BMW chips were silkscreened as -6 when they are really -V6 or whatever. But I guarantee that if you are trying to read those (and those are generally any BMW cluster chip from the early 2000's...), you need to use the ADP-088 pinout remapping, and ignore the posts and threads on this board that say the M38050-6 can use the ADP-004. That is not correct for BMW-cluster chips at the very least.





Good contribution.
Go to Top of Page
Reply #41

anniel

1996 Posts

Posted - 04/26/2018 :  15:01:25  Show Profile  Reply with Quote
quote:
Originally posted by vibroverbus

By the way I will add (since this thread deals with not being able to write brand new chips that read as all "00") I am still seeing this problem with the brand new V6 chips I have. Either programming voltage is too low, or there is a programming error, or, the chips are flawed or counterfeit or something. I've been told to go use a dedicated M35080 programmer but I really like my GQ honestly and seems like it should be able to work, unless its' purely a hardware / voltage problem (or the chips are truly bad..)



Counterfeits are common.
Go to Top of Page
Reply #42

anniel

1996 Posts

Posted - 04/26/2019 :  05:04:10  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by vibroverbus

By the way I will add (since this thread deals with not being able to write brand new chips that read as all "00") I am still seeing this problem with the brand new V6 chips I have. Either programming voltage is too low, or there is a programming error, or, the chips are flawed or counterfeit or something. I've been told to go use a dedicated M35080 programmer but I really like my GQ honestly and seems like it should be able to work, unless its' purely a hardware / voltage problem (or the chips are truly bad..)



Counterfeits are common.

http://www.mcumall.com/forum/topic.asp?TOPIC_ID=8418
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.33 sec. Snitz Forums 2000