MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 GQ-4X how to write MXIC MX25U6435F
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

83Air

Slovenia
9 Posts

Posted - 12/09/2015 :  13:04:08  Show Profile  Reply with Quote
Hi there
I have GQ-4X programmer and try to use MXIC MX25U6435F.
I did buy the appropriate adapters( ADP-099 and ADP-081a).
I don`t know which device to select(mx25u6435f is not on the list).

Any help is appreciated

datasheet
h**p://www.macronix.com/Lists/DataSheet/Attachments/3213/MX25U6435F,%201.8V,%2064Mb,%20v1.4.pdf
Reply #1

ZLM

2923 Posts

Posted - 12/09/2015 :  19:03:33  Show Profile  Reply with Quote
Try :


Name="MX25U6435F",ID="C22537",Class="W25X10",Category="SERIAL_EPROM",MFG="Winbond",Vcc="5V",CodeSize="8388608",Adapter="ADP-081+ADP-099 adapter",Message="Make sure the ADP-099 is used. The programmer will supply 5V voltage. Without ADP-099, the chip maybe damaged.";
Go to Top of Page
Reply #2

83Air

Slovenia
9 Posts

Posted - 12/11/2015 :  16:38:52  Show Profile  Reply with Quote
erase appears to work
blank check fails
read appears to work
write stuck at 0%
Go to Top of Page
Reply #3

ZLM

2923 Posts

Posted - 12/14/2015 :  20:44:12  Show Profile  Reply with Quote
does ID work?
Go to Top of Page
Reply #4

83Air

Slovenia
9 Posts

Posted - 12/15/2015 :  11:22:29  Show Profile  Reply with Quote
no, ID does not work.
Go to Top of Page
Reply #5

ZLM

2923 Posts

Posted - 12/15/2015 :  12:34:36  Show Profile  Reply with Quote
There are many factors cause the ID fail.

Try to use another supported chip to confirm the adapter ADP-081 and ADP-099 work. Then we can focus on the software.
Go to Top of Page
Reply #6

83Air

Slovenia
9 Posts

Posted - 12/16/2015 :  01:22:44  Show Profile  Reply with Quote
I tried to test with both adapters(ADP-099 set to 2.5V) on a MX25l8005m and i worked, ID check ok(correctly recognized eprom as mx25l8005m).
Go to Top of Page
Reply #7

83Air

Slovenia
9 Posts

Posted - 01/16/2016 :  04:20:12  Show Profile  Reply with Quote
It took me a while to get another mx25u6435f to test, still does not recognize the device.
Any ideas ?

Edited by - 83Air on 01/16/2016 04:21:01
Go to Top of Page
Reply #8

83Air

Slovenia
9 Posts

Posted - 01/25/2016 :  14:30:00  Show Profile  Reply with Quote
ID checks ok without ADP-099 on mx25u6435f
Go to Top of Page
Reply #9

ZLM

2923 Posts

Posted - 01/26/2016 :  10:43:11  Show Profile  Reply with Quote
OK. This one I think the software need a tweak. I will request a testing chip and hen test it then. I will post the result here.
Go to Top of Page
Reply #10

83Air

Slovenia
9 Posts

Posted - 01/26/2016 :  15:40:56  Show Profile  Reply with Quote
thank you
Go to Top of Page
Reply #11

ZLM

2923 Posts

Posted - 04/09/2016 :  17:19:33  Show Profile  Reply with Quote
I finally did a test on this chip with ADP-099.

However, there is a compatibility issue.

The only way to solve the problem is to modify the ADP-099.

Here is what I did:

1. changed R4,R5,R6,R7 to 100 ohm resistors.
2. added a 10uF capacitor on IC U1 pin 1 and 4. Pin 4 is ground, pin 1 is positive.

After modification, I successfully ID, read, erase, write, verify the MX25U6435F.


Image Insert:

174563 bytes
Go to Top of Page
Reply #12

83Air

Slovenia
9 Posts

Posted - 08/29/2016 :  02:37:31  Show Profile  Reply with Quote
I am sorry it took so long to reply.
The thing is it still doesn`t work, but that may be because i damaged the eeprom, when i was testing it without the adp-099 adapter, and i don`t have another mx25u6435f eeprom to test.
Go to Top of Page
Reply #13

pashha

Turkey
8 Posts

Posted - 12/25/2019 :  01:02:06  Show Profile  Reply with Quote
quote:
Originally posted by ZLM

I finally did a test on this chip with ADP-099.

However, there is a compatibility issue.

The only way to solve the problem is to modify the ADP-099.

Here is what I did:

1. changed R4,R5,R6,R7 to 100 ohm resistors.
2. added a 10uF capacitor on IC U1 pin 1 and 4. Pin 4 is ground, pin 1 is positive.

After modification, I successfully ID, read, erase, write, verify the MX25U6435F.


Image Insert:

174563 bytes



it works! Thank you dear (By the way.. 100 ohm resistor is labeled with 101)

GQ-4X
Go to Top of Page
Reply #14

anniel

2252 Posts

Posted - 12/25/2019 :  05:31:19  Show Profile  Reply with Quote
quote:
Originally posted by pashha

quote:
Originally posted by ZLM

I finally did a test on this chip with ADP-099.

However, there is a compatibility issue.

The only way to solve the problem is to modify the ADP-099.

Here is what I did:

1. changed R4,R5,R6,R7 to 100 ohm resistors.
2. added a 10uF capacitor on IC U1 pin 1 and 4. Pin 4 is ground, pin 1 is positive.

After modification, I successfully ID, read, erase, write, verify the MX25U6435F.


Image Insert:

174563 bytes



it works! Thank you dear (By the way.. 100 ohm resistor is labeled with 101)

Thank you for your testimonial.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.2 sec. Snitz Forums 2000