MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 M27C400,HN27C40000G
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

timepiloteer

USA
4 Posts

Posted - 01/10/2018 :  23:19:55  Show Profile  Reply with Quote
Hello,

I am trying to read and verify a couple of rom chips from an arcade board. These chips are custom mask roms from a cps1 arcade board, stamped HN62404P, which are pin equivalent to hitachi HN27C4000G eprom or M27C400, all 40 pin chips.

I am using the ADP-054 adapter in the GQ-4X. If I place the chip in the left 40pin socket, it will successfully complete reading the chip, but it reads garbage and none of the 5 chips verify against a mame rom set. I know they are not all bad.

If I place the chip in the right-most socket with 48 pin slots, when trying to read the chip, the programmer just hangs and sits with an empty progress bar. I have to remove power, unplug USB, restart the GQUSB Program, and replug in again to get it to work again.

I am on Windows 10, the J1 jumper is on 1-2, I've tried J5 with V3 and V4 with no different results.

Does this mean I have a bad adapter?

-Adam
Reply #1

timepiloteer

USA
4 Posts

Posted - 01/12/2018 :  08:59:11  Show Profile  Reply with Quote
Bump. Any ideas here?

I am using the generic 27c400 to read the roms, and if the chip is in the left slot, it will read nothing but FFFF for the whole buffer. If I put the chip in the right larger socket, the programmer will just hang. Is there anything I can do to further test if my adapter is working correctly?

-Adam
Go to Top of Page
Reply #2

anniel

1090 Posts

Posted - 01/13/2018 :  05:52:33  Show Profile  Reply with Quote
Your chip goes in the bottom of the right ZIF.
Go to Top of Page
Reply #3

timepiloteer

USA
4 Posts

Posted - 01/14/2018 :  00:19:01  Show Profile  Reply with Quote
Thanks, in the bottom of the right zif socket, trying to read the rom just hangs the program (never gets past zero %). This is with a 9v power adapter as well as only USB powered.

-Adam
Go to Top of Page
Reply #4

anniel

1090 Posts

Posted - 01/14/2018 :  03:25:03  Show Profile  Reply with Quote
quote:
Originally posted by timepiloteer

Thanks, in the bottom of the right zif socket, trying to read the rom just hangs the program (never gets past zero %). This is with a 9v power adapter as well as only USB powered.



Which of the devices did you try?
Go to Top of Page
Reply #5

timepiloteer

USA
4 Posts

Posted - 01/14/2018 :  16:38:06  Show Profile  Reply with Quote
I used the GQ-4X with the ADP-054 adapter, and set the device to 27C400, I also tried M27C400. In the right zif socket, the program just hangs reading the rom.

-Adam
Go to Top of Page
Reply #6

ZLM

2894 Posts

Posted - 01/14/2018 :  21:24:32  Show Profile  Reply with Quote
This problem may be caused by any of following reasons:

1. Bad EPROM chip
2. Bad USB cable.
3. The USB port does not provide enough DC current. Try another computer or use external power adapter.
4. Poor pin contacting between chip and adapter, or adapter with programmer.

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.11 sec. Snitz Forums 2000