MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 27C1001 Blank check problem
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

hanyfmankarios

Egypt
3 Posts

Posted - 12/18/2018 :  21:45:11  Show Profile  Reply with Quote
Hi everybody
I need to program a group of EProms 27C1001-12 , I bought brand new chips , but when I made a blank check to all of them, I got that are not blank, there are some bits that contain a small amount of data...Is that normal ?
and how about if I write my file to those chips? I didn't try... but I expect that when verified it will give error !!!
Please advise...
Reply #1

anniel

1996 Posts

Posted - 12/19/2018 :  08:08:21  Show Profile  Reply with Quote
quote:
Originally posted by hanyfmankarios

Hi everybody
I need to program a group of EProms 27C1001-12 , I bought brand new chips , but when I made a blank check to all of them, I got that are not blank, there are some bits that contain a small amount of data...Is that normal ?
and how about if I write my file to those chips? I didn't try... but I expect that when verified it will give error !!!
Please advise...




Where did you buy your "brand new" chips? Pictures?
Go to Top of Page
Reply #2

hanyfmankarios

Egypt
3 Posts

Posted - 12/19/2018 :  11:31:20  Show Profile  Reply with Quote
I bought them from a local market ( Electronic shop)
Go to Top of Page
Reply #3

anniel

1996 Posts

Posted - 12/19/2018 :  14:19:19  Show Profile  Reply with Quote
quote:
Originally posted by hanyfmankarios

I bought them from a local market ( Electronic shop)




I'm asking because those chips are out of production for eons now and you are probably dealing with fakes or pulls at best.

Did you try erasing the chips, unless you have OTP devices?

Do they ID correctly?
Go to Top of Page
Reply #4

hanyfmankarios

Egypt
3 Posts

Posted - 12/20/2018 :  23:29:32  Show Profile  Reply with Quote
I tried to erase other chips that are not new using a UV exposing device used for exposing PCB's for more than half an hour, but unfortunately data still not erased.

Concerning the chip ID ,I have to uncheck the "Check ID" button to be able to load the data stored on those "brand new" chips , other than that the read operation gives error.
Go to Top of Page
Reply #5

anniel

1996 Posts

Posted - 12/21/2018 :  05:08:32  Show Profile  Reply with Quote
quote:
Originally posted by hanyfmankarios

I tried to erase other chips that are not new using a UV exposing device used for exposing PCB's for more than half an hour, but unfortunately data still not erased.


You need a real chip eraser.

quote:
Originally posted by hanyfmankarios

Concerning the chip ID ,I have to uncheck the "Check ID" button to be able to load the data stored on those "brand new" chips , other than that the read operation gives error.



There is no way those chips are new if data is present on them.
Moreover if the ID does not correspond to the datasheet your chips are fake.

http://www.mcumall.com/forum/topic.asp?TOPIC_ID=8418

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.19 sec. Snitz Forums 2000