MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 PIC Programmer
 no red light on JDM enhanced programmer
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Bobino36

3 Posts

Posted - 09/26/2007 :  17:02:24  Show Profile  Reply with Quote
Hi!
My enhanced JDM programmer works well on my pc (can read, write, erase, both light green and red, are working)with a 16f628a.

But when I try with my laptop, it's a no-go. I know voltages in serial port on laptop are lower that's why I put an external voltage supply (+12Vcc). I double-checked polarity and it's ok. The green light is on only when I do a read command but no red light when trying to write. I can read but that's all. I use ICprog. I thought this programmer would work with any laptop with an external source???

I also checked VCC and VPP on the ICSP connector when reading and it shows 4.4V and 11.5V

Any hints???????
Thanks.

Edited by - Bobino36 on 09/26/2007 17:11:43
Reply #1

ZLM

2923 Posts

Posted - 09/27/2007 :  09:31:16  Show Profile  Reply with Quote
If you can read, then you should be able to write. The read and write have same voltage requirment and only software commands are different.

The external Vpp will not let red LED on. It only applied on chip.

How about the voltage measurment without external Vpp?


Go to Top of Page
Reply #2

Bobino36

3 Posts

Posted - 09/29/2007 :  05:09:02  Show Profile  Reply with Quote
Vpp = 9.21V
Vcc = 4.43V

While using JP2 2-3 (internal Vpp)

Any suggestion would be appreciated.

Thanks.


Edited by - Bobino36 on 09/29/2007 05:10:13
Go to Top of Page
Reply #3

ZLM

2923 Posts

Posted - 09/30/2007 :  19:57:17  Show Profile  Reply with Quote
Try to connect the 12V external VPP only before hit the read/write button. and disconnect it after finished read/write.
Go to Top of Page
Reply #4

Bobino36

3 Posts

Posted - 10/01/2007 :  17:39:40  Show Profile  Reply with Quote
I tried your suggestion but it seems to be working normally even if I let the supply voltage always on!?!?! I don't understand why and I did no change.... Altough the red light only blinks 2 small shots, the pic 16f628a is correctly programmed. It is strange because on my desktop, the red light goes on for much longer time...

Do you provide the schematics of this board? I wonder what is driving the RED "program" led to see why it's missing voltage and to see if I would be able to find something to fix this...

Thanks.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.09 sec. Snitz Forums 2000