MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 TOP USB Programmer
 TOP2005 Topwinen v2.35 Config

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List Spell Checker
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File
Check here to include your profile signature.
    

T O P I C    R E V I E W
Goonie Posted - 04/18/2007 : 05:51:18
Hi,

I am having problems getting my PIC (16F877) to work. I've tried my code on other programmers and it has worked fine and when using the TOP2005 it seems to write and read correctly, but doesn't work so I can only assume it's the config. To make things a bit more difficult the manual I got with the programmer doesn't have the config screen that comes up in my version of Topwinen so I don't actually know what most of them mean. If anyone knows and can help I'd much appreciate it. They are as follows:-

FOSC0
FOSC1
WDTEN
PWRTE
CP0
CP1
BODEN
LVP
CPD
WRT
RESV
CP0
CP1

It also says "Config(Cheoked=0)". I gather it should say "checked" and saying checked = 0 means if I tick the box next to the function it is off, does that sound right, I'm used to ticking boxes meaning on? I'm also not sure why CP0 and CP1 are shown twice.

Any help would be great.

Cheers,

Markus
1   L A T E S T    R E P L I E S    (Newest First)
CostaRica Posted - 04/29/2007 : 19:51:43
I had the same problem with my top2004, the solution is very easy,you have to read the data sheet of the pic16f877A in the seccion named CONFIGURATION WORD (ADDRESS 2007h)(1) in my case is the page number 146 of the .pdf or you can try it with this configuration(please tell me what happens with your new configuration at emamacu@yahoo.com):

FOSC0
FOSC1
WDTEN
PWRTE
CP0
CP1
BODEN
LVP
CPD
WRT
RESV
CP0
CP1


MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.3 sec. Snitz Forums 2000