MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Trouble reading 27C256

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List Spell Checker
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File
Check here to include your profile signature.
    

T O P I C    R E V I E W
midge Posted - 11/15/2009 : 11:38:28
Right ive got a willem pcd5.0 programmer i bought it so i can copy eprom chips, the chips im trying to read/write are m27c256b, so i select 27c256, when i do a blank test it says device not empty even though these are brand new chips! so i took the chip out and done a blank test again, and i got the same thing, 'device not empty' theres no bloody chip init! when i go to the buffer after reading a chip that isnt there every field except the last long column is showing '04'

i think i have the jumpers setup correctly but im not to sure, and i cant find any instructions!

the prgrammer is a pcb50, however the software wouldnt work with it, so im using pcb3 software, and set the jumpers up to be on pcb3.

someone help me! im going crazy!

this is the programmer i have
www.cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=250515051754&ssPageName=STRK:MEWNX:IT

thanks for anyhelp
3   L A T E S T    R E P L I E S    (Newest First)
simeon Posted - 01/23/2010 : 07:00:37
hi

first clean the pins of the chip carefully
i use flux and solder iron careully

next set the jumper on the right that says 5v and 5.6v to the middle to dock it there ie the jumper is off
this is programming level vcc=6250 {best use ac supply for eproms i find}

use pcb5.0c setting and pcb5 app again version ja works for me
but so did the one i got with the unit

the only eprom ive had trouble with so far are 27c1000 it appears so does the top programmer even with tweaks
see's a bad chip at &1000 but willem does test blank but fails at $1000 so its something strange and defo an application error

256k was fine i use dual power willem blue pcb extra sockets on it for plcc on the right

as ive said before there are rules to programming
and the jumper is one of them i find in read or write
James B Posted - 01/16/2010 : 11:58:13
Midge, try software version 0.97ja. I had the same issues and it's finally solved mine. I have now been able to read chips, and blankcheck/program/verify/read 27C256 chips too.

It's here:

h**p://www.sivava.com/Software/MCUsetup97ja.zip
simeon Posted - 11/16/2009 : 17:11:48
if your stuck i can offer help on msn i have a dual power willem programmer
and program many eproms for the retro computer scene
its a great tool
some need a few bits advice

you can email me your msn details to vsmlibs@talktalk.net
and ill add you as msn can be a bit funny with new contacts sometimes
or ill help on msn passport email simeon.webber@ntlworld.com

youll get me there
i have flashed many eproms 27c cmos 27XXX nmos{most} even older 27C204 and 240 and 2048 plcc
with no issues

ps
never plug a chip in till you measure a few voltages using the apps test tools
bit of advice
an lcd volt meter is your chips friend and you its keeper
use the tools make sure of things
BEFORE plugging a chip in
think of chips as soldiers
and dont waist them over simple mistakes....!
in all modes !!!!

MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.11 sec. Snitz Forums 2000