MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 TOP USB Programmer
 Can't install TOP2049
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

CactusJack

USA
4 Posts

Posted - 04/22/2008 :  10:23:30  Show Profile  Reply with Quote
I just purchased a TOP2049 and I cannot get it to communicate sucessfully with the TOPWIN3X software.

I install the TOP software, click on the Install USB Driver, wait for the hard drive access to stop, click on Continue and then Finish the installer. I never get a Blank screen like the manual talks about, and since it mentions restarting, I then shut down the computer and then restart it BEFORE trying to plug the Programmer in to the USB port.

When I plug the TOP2049 in to the USB port (no other devices currently plugged into USB) Windows Installer Wizard comes up, I direct it to the DRIVERS folder under TOP. It states it has successfully installed the device and it is ready to use.

When I launch TOPWIN software, It opens the Self Diagnosis Panel, Blinks the Green LED a few times and then leaves it on and then give me an ERROR! with various numbers each time (some of them have been 5637504, 5899652, 4851060)

Each time I plug the Programmer into the USB port, Windows re-launches the Install Wizard and goes through the process of searching for a driver etc.

I started by trying to install it on my laptop and after numerous failed tries, I tried it on a Desktop. Both running XP SP2.

Since the Small CD that came with it was bad (couldn't read SETUP.EXE in the English folder), I downloaded TOPWIN3X (3.25) and then later tried 1.41.

Anyone have any ideas what I am doing wrong?

Thanks.
Reply #1

ZLM

2926 Posts

Posted - 04/22/2008 :  10:39:37  Show Profile  Reply with Quote
Remove the chip in the ZIF socket when software starting up.
Go to Top of Page
Reply #2

CactusJack

USA
4 Posts

Posted - 04/22/2008 :  11:21:30  Show Profile  Reply with Quote
There is no Chip in the socket. I have used a number of EPROM programmers over the years and know better than to power up a Programmer with a chip installed in the socket!!!
Go to Top of Page
Reply #3

ZLM

2926 Posts

Posted - 04/22/2008 :  16:38:17  Show Profile  Reply with Quote
Your programmer may have some problem internally. Such as internal contacting.
Go to Top of Page
Reply #4

CactusJack

USA
4 Posts

Posted - 04/23/2008 :  09:01:07  Show Profile  Reply with Quote
Thank you for the help. I just wanted to make sure I wasn't doing anything wrong on my end before returning it.
Go to Top of Page
Reply #5

simeon

United Kingdom
79 Posts

Posted - 04/24/2008 :  07:15:15  Show Profile  Reply with Quote
hi

what i did to get the top programmer to work
is installed windows xp service pak3
then powerup and plug in the programmer {power it first}
then windows will ask for a driver
click dont install just now

then install the software topwin 3.26 from there site
click install the usb driver

then once its installed reboot leave the programmer attached
go to the device manager and confirm that you have
two entrys under the jungo entry

one says windriver the other top programmer

if you dont and or have just one
check for a yellow exclimated one or go to the top programmer one
and click update driver and
choose to install from the list
then point it to the driver folder in topwin install


you need to first install windriver then the usb driver
but sp2 can have issues with it
i did find adding vc2005 runtime helpfull also .net 1 2 and 3 and there fixes
these dont get offered in the update windows effort by microsoft
however service pak 3 puts them all there


good luck took me a while but its a nice programmer for what i payed
even if it wont blast at the older eproms yet...
i think there software will work better soon
Go to Top of Page
Reply #6

presepio58

1 Posts

Posted - 05/31/2008 :  01:34:58  Show Profile  Reply with Quote
Hello CactusJack

I have the same problem. I installed the software and the drivers and when i connect the device the system recognizes the programmer and not require me to install drivers.
Have you solved this problem ?
Go to Top of Page
Reply #7

CactusJack

USA
4 Posts

Posted - 06/21/2008 :  11:31:41  Show Profile  Reply with Quote
I had to send the unit back to China to the manufacturer to repair. It came back and appears to be working okay now. I plugged it into a computer I had already loaded TopWin and launched the application and it communicated just fine. So, the problem was definitely in the TOP2049 head since I didn't change anything else when I got it back.

CJ
Go to Top of Page
Reply #8

tinhead

Germany
10 Posts

Posted - 04/13/2009 :  03:54:26  Show Profile  Reply with Quote
a bit old thread, however, i had similar issues, with my top2049 - easy resolved, it seems that sometimes pins on the Xilinx Spartang FPGA are not really soldered - in my case two pins, so have resoldered and was ok ..month later another one pin was not contacting, so finally have reassembled the programmer and resoldered the FPGA - lucky to have reflow oven.

Maybe not the perfect way to handle warranty things, however, it was faster and easier than send back to China.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.25 sec. Snitz Forums 2000