MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 TOP USB Programmer
 PIC16F84A not able to program chip at all
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Leo

3 Posts

Posted - 01/22/2006 :  15:29:53  Show Profile  Reply with Quote
I Just purchased a top 2005 and I am not able to program the pic16f84a at all. I have tried many things Like changing the config setting and different hex data. When I program the chip everything looks great when I verify or read the chip it shows that the chip is empty. The Programmer itself shows that it is working correctly. I Am Very Very New to this hole programing thing, and from what I have been reading no one else really seems to have this problem. I was wondering if the chip itself would reject certain hex file or what. All that I want to do right now is put information into this chip then be able to verify the information is there can some one please help.
Tank’s in advanced,
Leo

Edited by - Leo on 01/23/2006 14:41:00
Reply #1

ZLM

2926 Posts

Posted - 01/23/2006 :  23:02:19  Show Profile  Reply with Quote
Looks like the chip been protected. Turn off all CP(code protect) bits. OR just write a simple program to see if it works.
Go to Top of Page
Reply #2

Leo

3 Posts

Posted - 01/24/2006 :  11:59:38  Show Profile  Reply with Quote
I have tried enabling and disabling the cp option and still nothing seems to work. I have tried reading the data off the chip and changing a few numbers then try to re-program it but when I read the data again I get (ff 3f ff 3f ff 3f) which tells me nothing programmed. Is there a specific procedure that I am not following? The way I program the chip seems logical to me.
Erase
Blank
Program
Verify >> at this point I always get an error (Verify error)
Read >> data comes back as (ff 3f ff 3f ff 3f etc)
This May be the wrong way of going about it I am stumped.
I have been trying to figure this out for days now.
Thank you,
Leo
Go to Top of Page
Reply #3

daven3

Australia
1 Posts

Posted - 10/31/2006 :  19:38:38  Show Profile  Reply with Quote
About 5 people in our class also bought the Willhem programmer to program the PIC16F84A chips. We are all getting exactly the same problem with the Verify not working with our programmers. Please advise as to how to solve this problem...

Also we have tried with and without the Code Protect bit set, this makes no difference.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.28 sec. Snitz Forums 2000