MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 TOP USB Programmer
 Top 2004 and Windows Vista
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

channelmaniac

4 Posts

Posted - 04/02/2007 :  11:32:48  Show Profile  Reply with Quote
Hrmmm...

I get the dreaded "A service installation section in this INF is invalid." and the driver refuses to load.

Are there any workarounds for this or am I doomed to wait for a Vista driver?

Thanks,

RJ
Reply #1

channelmaniac

4 Posts

Posted - 04/22/2007 :  20:55:42  Show Profile  Reply with Quote
OK...

Got the drivers to load... but it won't "see" that it's loaded... dangit...

Here are the changes I made to the .inf files to get this far...

Enjoy!

RJ

--------------

Change the following in topwin.inf

Change: ServiceBinary = %10%\System32\Drivers\windrvr6.sys
To: ServiceBinary = %12%\System32\Drivers\windrvr6.sys

Change: DefaultDestDir=10, System32\Drivers
To: DefaultDestDir=12, System32\Drivers

Change: 1="TY51 Installation Disk",,
To: ;1="TY51 Installation Disk",,

Add this line to the [SourceDisksFiles] section:
windrvr6.sys=c:\top\topwinen\driver

--------------

Change the following in windrvr6.inf

Change: DefaultDestDir=10,System32\Drivers
To: DefaultDestDir=12,System32\Drivers


Change: 1=%INSTDISK%,,,.
To: ;1=%INSTDISK%,,,.

Change: ServiceBinary=%10%\system32\drivers\windrvr6.sys
To: ServiceBinary=%12%\system32\drivers\windrvr6.sys

Change: windrvr6.sys=1
To: ;windrvr6.sys=1

Add the following line to the [SourceDisksFiles] section:
windrvr6.sys=c:\top\topwinen\driver
Go to Top of Page
Reply #2

channelmaniac

4 Posts

Posted - 04/22/2007 :  21:01:23  Show Profile  Reply with Quote
This is frustrating... I've set compatibility mode on Vista... and have granted the app "run as administrator" privileges...

All I get is "Driver not ready,if load it now?"

What a PITA.

Anyone else ever get this to run successfully under Vista?

Edited by - channelmaniac on 04/22/2007 21:02:09
Go to Top of Page
Reply #3

ZLM

2926 Posts

Posted - 04/23/2007 :  00:13:51  Show Profile  Reply with Quote
I got seem problem on Win2000. So, it is not the VISTA driver problem, it is a software bug.
I used a different version software and then it works.
try :
http://www.mcumall.com/download/all/topwinen1.44.zip

Install this version under different directory and try.
Go to Top of Page
Reply #4

ericko

Mexico
1 Posts

Posted - 05/01/2007 :  21:31:34  Show Profile  Reply with Quote
I tried TopWinEn v1.44 under Vista, but the installer doesn't even opens.

Anyone has find a solution?
Go to Top of Page
Reply #5

ZLM

2926 Posts

Posted - 05/03/2007 :  07:19:14  Show Profile  Reply with Quote
Install 1.44 on other NOT vista computer, and then copy whole directory to Vista.
Go to Top of Page
Reply #6

muvel

USA
1 Posts

Posted - 09/16/2007 :  04:54:41  Show Profile  Reply with Quote
All,

I manually copied the windrvr6.sys to ..\system32\drivers\ folder and
driver gets successfully installed. What's really missing now is
WinDriver driver installation. For some reason the version supplied with the install kit is not getting loaded or activated.

Anyone figured out a fix for this issue?

mraju

Go to Top of Page
Reply #7

pic

United Kingdom
3 Posts

Posted - 11/13/2007 :  11:21:23  Show Profile  Reply with Quote
hi am kez . im wanting o get the top 2004 or 2005 programmer im new to pic prog but these are nicely priced and will prog millions of different pic ect which is the best model and will i have the same probs runing on crapy vista thanks
Go to Top of Page
Reply #8

ZLM

2926 Posts

Posted - 11/15/2007 :  01:17:16  Show Profile  Reply with Quote
The TOP programmer currently does not work on Vista yet.
Go to Top of Page
Reply #9

pmcleod

United Kingdom
1 Posts

Posted - 03/22/2008 :  11:23:44  Show Profile  Reply with Quote
Is there any progress on getting topwin to work with vista yet?

Peter McLeod
Go to Top of Page
Reply #10

SUB

France
1 Posts

Posted - 09/08/2011 :  08:17:05  Show Profile  Reply with Quote
Hi, Drivers for Vista (x86&x64) here : h**p://drivers.spi-tech.info/

i know they are not perfect but working on vista & WIN7 32&64bits

More information in the comment here : h**p://blog.savel.org/2007/05/13/top2004-programmer-review/

sub

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.19 sec. Snitz Forums 2000