MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Problems reading 27C512

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert EmailInsert Image Insert CodeInsert QuoteInsert List Spell Checker
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

   Insert an Image File
Check here to include your profile signature.
    

T O P I C    R E V I E W
MikeM Posted - 03/26/2005 : 18:21:40
Hi,

I recently acquired a Dual Power Programmer, and have been simply trying to read and burn 27C512s, but have had no success. The programmer is set as shown when a 27C512 is selected, but reading a programmed eprom results in garbage. Results are different when reading with nothing in the eprom socket so it seems to be looking at the hardware, but the data is not intact. This was also tested on another pc with the same results.

I tested all the I/O lines and they correctly toggle from 0v to either 5v or Vpp depending on the tested pin (with one of the address pins reading a little low as it should). I also connected ZIF pins 2 - 9 to pins 13,14,15, 17, 18, 19, 20, and 21 respectively, and tested its ability to read data (by toggling the connected address lines). The data appears to be read correctly, however there was something strange. Whenever data bit 5 was set to 0, the "Data In" field displayed only a single hex digit. For example, if the data in I/O lines were set to: D0, the 'Data In' field displayed "0xD". Actually, no matter what the lower 4 bits were set to, 'Data In' still showed "0xD". I'm guessing this is probably a bug in the display routine for the software, but it does prevent me from verifying that data in is working.

Anyway, if anyone has any suggestions, they would be greatly appreciated!

- Mike
2   L A T E S T    R E P L I E S    (Newest First)
effesse Posted - 09/17/2010 : 13:54:12
Hi all, I have Willem PCB3B (modded by myself only to erase/write the W27E512 chips) that actually don't read very well the 27C512 chips at all.
On each reading I get different results, but the more strange thing is that without putting the 27C512 into the 32 pin socket, the Willem read not all '00' as it should be, but read randomly.
I desoldered the original 32 pin Ziff socket because of dirty and soldered a new 32 pin 'tourned' socket, but without success.
I will attach a file in .JPG format to show well to you what I want to say.
I need some help to identify if there is a IC that can be blow or something else that affect the normal 27C512 readings.

Thanks in advance for all your replies and sorry for my bad English, kind regards, Stefano.
.


Image Insert:

100.85 KB
mcumall Posted - 04/01/2005 : 17:20:35
The 27C512 should work with no problem. Just confirm the jumper and DIP setting.

The latest software should be Re0.97ja. I tested on this revision and the data reading field is correct.(two digits).

Another reason is your Windows font size is too big, it got truncated in the display field. Config your windows font size to smallest and see.

MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.17 sec. Snitz Forums 2000