MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using the AVR JTAG ICE and AVRISP ISP programmer
 AVRISP does not download
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

BlueSky

14 Posts

Posted - 12/04/2007 :  15:53:12  Show Profile  Reply with Quote
My AVRISP does not download the code to my target chip Atmega16. I did check all settings in software. What could be wrong?
Reply #1

ZLM

2936 Posts

Posted - 12/04/2007 :  15:54:05  Show Profile  Reply with Quote
There are two possibilities for this kind of issue:

1. Hardware connection. Please confirm all connections are correct to the ISP header. The connecting should be pin to pin. eg. MOSI pin to MOSI pin. All GND pins on the ISP header should be connected to the GND of your target chip. The ISP header pinout please see:
h**p://www.mcumall.com/forum/topic.asp?TOPIC_ID=343
Also, the target chip need to be powered externally. The ISP programmer does not power the target chip.

2. Target configuration. Please confirm the chip fuse bit are set to the correct setting for the ISP feature.
....a. The ISP bit must be enabled so that to accept the ISP programming mode request. If this bit is disabled, then there are no way to program the ISP via ISP mode and only can enable this bit by parallel programming.
....b. The clock divider bit must not be set. The CKSEL fuse bit is another one need to care.
....c. All the default fuse value should work for the ISP programming. So, try with a brand new chip to eliminate the fuse setting factor.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.12 sec. Snitz Forums 2000