MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Problem with 29F002 (pm29F002T)
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  


3 Posts

Posted - 09/19/2006 :  08:21:50  Show Profile  Reply with Quote
I have a Dual Powered Willem Programmer.

I have successfully programmed several different types of chips with it: 27C256, 29F256, 27C1001, 29F1001

I have not been able to program a PM29F002T.

I am using 0.97ja of the software
It is powered by USB.
I select 29F002

I am able to ID the chip.
I seem to be able to read the chip.
If I try to erase the chip, the software almost immediately completes the action. (and a subsequent read shows that it is not erased)
If I try to program the chip I get an error. It is something like:
verify error at 0x036ba5 chip=0xff buffer=0xbf

I dont think it is a problem with the cables since it works for other chips.
I also tried using 0.97g of the software but was unsuccessful.
I tried posting to the willem forums but have not gotten a response.

Any suggestions or advise are appreciated. I am a newbie and up until now I have had no problems (with smaller chips).

If this is a known or expected problem, can anyone suggest a programmer that they "know" will work with 28/32 PIN DIP EPROM and Flash chips from 256kbit to 4 Mbit.

Reply #1


2942 Posts

Posted - 09/19/2006 :  15:28:33  Show Profile  Reply with Quote
If you can get ID correctly, then most likely the programmer is fine.

Did you do the blank check after erase?

Is it always write failed at the same location?
Go to Top of Page
Reply #2


3 Posts

Posted - 09/20/2006 :  05:48:02  Show Profile  Reply with Quote
I appreciate the response.

Using 0.97ja:

If I do an erase is completes very quickly and says: "erase completed by check DQ7"

If I then do a blank check it says: "Device is NOT Empty ($000000)"

When I program the chip it says: "Error at 0x000016 Chip=0xFF buffer=0xC6

It fails at a different location each time. (0x0000C2 then 0x00013B
then 0x00013C)

ID information:
Manufacture: 0x9D (PMC)
Device Code: 0x1D (PM29F002T)

Using 0.97g is more promising:
For erase and Blank Check, I get the same behaviour I listed above for 0.97ja.
I get a different behaviour when I program it though. Programming the chip does NOT fail right away. It fails at 96%. "Error at 0x03E0F1 chip=0x27 buffer=0xA7"
The next attempt failed at a different spot with: "Error at 0x03E0B4 Chip=0x1F buffer=0x9F"

Note: I have several chips. I have run these tests on 2 different chips to try to rule out a bad Flash chip.


Go to Top of Page
Reply #3


2942 Posts

Posted - 09/25/2006 :  15:52:40  Show Profile  Reply with Quote
The chip not been erased at all.

Posibly reason is: your chip may be damaged already.

Edited by - ZLM on 09/25/2006 15:54:12
Go to Top of Page
Reply #4


3 Posts

Posted - 02/21/2007 :  10:26:01  Show Profile  Reply with Quote
I wonder if its related to the "boot block"

I was able to find the specs for these chips and the boot block is located at: 3C000h-3FFFFh

So maybe I need to disable security somehow???

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.12 sec. Snitz Forums 2000