MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 Yet another 27C400 problem
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  


18 Posts

Posted - 12/03/2015 :  12:45:32  Show Profile  Reply with Quote
I should really call this "Yet another Willem Programmer problem", but whatever.
I originally had a PCB5.0 programmer, and that died after less than 10 chip burns.
I purchased a GQ-4X about 6 months ago, burned a custom Amiga Kickstart image with it, and put it away. Now I need to burn the same kickstart image again, so I break out the GQ-4X, the ADP-054 and commence to burning. This time It fails at 6% with the following error message:
Write failed, Address=0x008000, Buffer=0xFF Device=0x11

I have 4 AM27C400 chips, all of them freshly erased (60 min erase time), and all fail at exactly the same spot.

There have been no hardware changes on my computer, and the only software changes have been windows updates and video card drivers.

What are my options? This thing has literally burned ONE chip. That's all. Are these burners just horrible pieces of crap? I mean, I had the PCB5.0 that died after roughly 10 burns and this one which appears to be busted after only 1 burn.

Here's my setup:
Windows 7 Pro
GQ-4X programmer

Powering the programmer via USB (I have tried front panel and rear panel, the result is the same)

ADP-054 jumper set to V4, 27C400 is in the larger slot, with the notch facing the lever, and the chip all the way to the opposite end of the slot.
I have tried changing the write speed, but nothing changes.

Please help. I have just about had it with this stuff. It seems every time I need to burn something (Even if it's EXACTLY THE SAME as the last thing I burned), I end up here because the damn thing has stopped working again.
Reply #1


2939 Posts

Posted - 12/03/2015 :  21:53:01  Show Profile  Reply with Quote
If both chip fail on same address 0x008000, it should be the address pin A15 bad. It could be bad contacting. Try to wiggle the chip/adapter little bit after lock the ZIF socket handle. That helps on pin contacting between chip/adapter and the ZIF socket.

On the ZIF socket, the A15 is pin 7 pf ZIF socket.

On adapter, the A15 goes to pin 33 of the 27C400.

Check this pin on all points.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.27 sec. Snitz Forums 2000