MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 m27c160 eprom chips glitching on Snes
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  


3 Posts

Posted - 01/21/2017 :  10:59:22  Show Profile  Reply with Quote
Ok to make a long story short:

GQ-4X programmer

December 2015 I purchased a batch of chips, snes games programmed and verified but displayed graphical glitches in games. Other batches of chips programmed fine.

Fast forward to last month December 2016 I purchased another batch of chips and they again program w/glitches.

So since the last batch to this new batch I started making Genesis games and was not having any problems. So I took these chips and programmed a genesis game and the game works fine. So I went back and tried other snes roms and again glitches.

So being the hoarder I am, I saved the batch of chips from 2015. I went back to those chips grabbed a chip and made a genesis game no problems. I took another chip and tried a snes game and again graphical errors.

What is going on here?

All chips are 100F1

I have an external power supply I purchased because programming genesis w/out it will not work. I do not care what anyone tells you this GQ-4X requires an external power supply. It is not possible to program a genesis game w/out an external power or it will glitch and freeze regardless of chip size.

I have ADP-054 adapter.

Jumper is set on V4 but I believe my programmer may be a V3 as it does not yield 2 beeps at power on. Programmer upc= 6 26853 10032 4

I have programmed on both jumpers V3 and V4 and yield same results.

I use usb 2.0 and version 6.36. I had nothing but problems with 6.38 so I went back to 6.36 and all newer versions are said to be for the new GQ-4X which I have tried but they will not work.

Windows 7 64 bit

Edited by - icemanxp300 on 01/21/2017 11:01:49
Reply #1


2939 Posts

Posted - 01/21/2017 :  19:35:00  Show Profile  Reply with Quote
It seems you are programming the UV type EPROM chips.

Most likely the problems come between chips, the difference of the chips. Some old chips may have marginal data after write and installed in a different system.

Try followings:

1. Extend the UV Erase time. Make sure the chip is completely erased.
2. Slow down the programming speed. Eg. use slowest speed -2 to see if it fixes the problem.
3. Do multiple write. After a successful write, do not remove the chip, repeat the write on the same chip. You can do repeat write any times you want. This will reduce the marginal write problem if there is.
4. To isolate the power problem, in your game circuit, add a bigger capacitor on the chip VCC-GND, to reduce the power noise issue.
Go to Top of Page
Reply #2


3 Posts

Posted - 01/22/2017 :  06:32:34  Show Profile  Reply with Quote
Thanks for the reply. I will never do that again LOL.

I did a write on -2 and checked double write. What normally takes 8 minutes to write at +2 took 2 hrs and 17 minutes just for 1 write and then it started over, unreal. So a grand total of like 4 hrs and 35 minutes it took to write twice on -2 and then it failed the verify and game wouldn't load at all.

I am not sure I comprehend what you are saying in number 4, what power noise issue?

Edited by - icemanxp300 on 01/22/2017 11:44:43
Go to Top of Page
Reply #3


3 Posts

Posted - 01/22/2017 :  11:47:09  Show Profile  Reply with Quote
It has come to my attention that the most likely cause of this is the speed of the chips. Even though they are all suppose to be the same I don't think they are. I think somehow some of these chips have slowed down over time and that would explain why they will only work on genesis. Apparently genesis can utilize a much slower speed than snes and this is likely the cause of the problem. I just need to see if I can somehow test the speed of these chips.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.34 sec. Snitz Forums 2000