MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 Problem with ST M27C256B
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

cmazzanti

1 Posts

Posted - 05/01/2008 :  22:15:02  Show Profile  Reply with Quote
Trying to program ROM code into a several UV erasable ST M27C256B chips. Programmer is a GQ-3X Re-1.00. I select the exact chip type, blank check, load the bin file and program. Every 128th byte does not program. In other words, $7F, $FF, $17F, $1FF, etc, are unprogrammed (data value = $FF). The only exception is the LAST byte in the buffer, $7FFF, which programs fine.

This seems to only happen with ST M27C256B devices. I tested programming the same BIN file into a TI TMS27C256 and a Microchip 27HC256 and both programmed just fine. I have tried programming 6 different ST devices, 4 of which were brand new from the manufacturer. All had the same problem. I have also tried lowering the speed, doing a double write, and changing devices to the generic 27C256. Each time the results are the same - I cannot program the ST devices.
Reply #1

ZLM

2926 Posts

Posted - 05/02/2008 :  16:46:03  Show Profile  Reply with Quote
For some batch of M27C256B production. Add a 1K resistor between chip pin 20(CE) and pin 14(GND) will help to solve the problem.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.38 sec. Snitz Forums 2000