MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Trouble with 27c160s
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

ToplessZ

5 Posts

Posted - 11/15/2009 :  12:06:35  Show Profile  Reply with Quote
I have a PCB5.0c and the 16bit adapter.
I can read them but I cant progam them?
Im using the USB for power, I also tried a 12v 1amp adapter.
All the jumpers are set as shown in the software.
Any help would be greatly appreciated!

Edited by - ToplessZ on 11/15/2009 12:08:53
Reply #1

simeon

United Kingdom
79 Posts

Posted - 11/16/2009 :  16:50:19  Show Profile  Reply with Quote
first usb volts isnt enough for older eproms
you need +vcc supply also i think 12v is fine on the plug
remove the usb power
set the jumpers for 12v power lower right of the boards...


you also need to remove the jumper on the voltage select pins J8 on the right
to allow 6.250v as vcc when applying programming volts of ~12vpp
it says

. 5v6
. com
. 5v

but remove it its ~6.250v perfect for 27cxxxx or 27xxx
i made this mistake

i adjusted the block for switches and jumpers as per

then tried to program
and no error till it varified then blocks failed

it says nothing about it but J8 you need to basicaly remove
just park it on the middle pin for vcc=6.250v {program level of any...27c series where 27xxx need vcc=6.000v you can use the same 6.250v its ok... i suppose}
then youll get the correct programming volts

simply unlike automated units
this is why this programmer works

for me anyway....
one of the best tools i bought for $18 free post...

i dont mind the 'real' parallel port i have a few of them

never throw a computer 'away'

machine toshiba equium laptop usb only type
p5b asus main machine
thinking of adding dual lpt pci card
both used for top and lpt via usb where i can

old p2 programming grumbling tank with xp sp3 for true serial and lpt

all machines bios set to enable bios plug and play aware o/s and lpt spollers services and drivers removed
legacy detection enabled

Edited by - simeon on 11/16/2009 17:03:32
Go to Top of Page
Reply #2

simeon

United Kingdom
79 Posts

Posted - 11/16/2009 :  16:58:20  Show Profile  Reply with Quote
place fresh eproms in the freezer for 15 mins first
before programming
it weights there memory cells heavier with electrons inside them when you program becouse less of them escape as things are cold they will leave a zone less readily
leading to a stifer image on reads over a vcc range
and less electron leekage on program runtimes...


so... better to freeze first but also blank check first before freezing

machine toshiba equium laptop usb only type
p5b asus main machine
thinking of adding dual lpt pci card
both used for top and lpt via usb where i can

old p2 programming grumbling tank with xp sp3 for true serial and lpt

all machines bios set to enable bios plug and play aware o/s and lpt spollers services and drivers removed
legacy detection enabled

Edited by - simeon on 11/16/2009 17:05:40
Go to Top of Page
Reply #3

ToplessZ

5 Posts

Posted - 11/17/2009 :  06:37:17  Show Profile  Reply with Quote
STill no luck..
I removed Jumper on J8 and left it empty, I set the jumper on bottom right to VCC and used my 12v power source. I still get an error immediately on programming?/
Go to Top of Page
Reply #4

simeon

United Kingdom
79 Posts

Posted - 01/23/2010 :  07:08:11  Show Profile  Reply with Quote
what is the error
please specify it ???
is it write failure is there an address

???


you maybe didnt follow rules

for eprom blank them
test blank
freeze for 30 mins
then blank check again
then program using 6.250
@ <=100ns = 100us delay or >=~120ns = 200us delay and delay/4 = sub delay
if you blank check @ 5v and 6250 ok,,,
then fill then buffer with 00 and varify this ensures first byte reading
this can check two states i find
so.. sometimes the software doesnt check a disconected vpp pin
om in read but write fails on the first byte or two etc

i clean the pins with a burnish pencil first
to ensure connection
as only write uses this pin on the eprom in question

machine toshiba equium laptop usb only type
p5b asus main machine
thinking of adding dual lpt pci card
both used for top and lpt via usb where i can

old p2 programming grumbling tank with xp sp3 for true serial and lpt

all machines bios set to enable bios plug and play aware o/s and lpt spollers services and drivers removed
legacy detection enabled

Edited by - simeon on 02/03/2010 09:42:02
Go to Top of Page
Reply #5

maxheadr00m

United Kingdom
3 Posts

Posted - 04/25/2011 :  13:09:31  Show Profile  Reply with Quote
did you get this to burn the 27C160'S?
Go to Top of Page
Reply #6

jamesss86607

India
1 Posts

Posted - 10/09/2013 :  20:36:37  Show Profile  Reply with Quote
or eprom blank them
test blank
freeze for 30 mins
then blank check again
then program using 6.250
@ <=100ns = 100us delay or >=~120ns = 200us delay and delay/4 = sub delay
if you blank check @ 5v and 6250 ok,,,


you also need to remove the jumper on the voltage select pins J8 on the right
to allow 6.250v as vcc when applying programming volts of ~12vpp
it says

. 5v6
. com
. 5v

but remove it its ~6.250v perfect for 27cxxxx or 27xxx
i made this mistake

i adjusted the block for switches and jumpers as per

then fill then buffer with 00 and varify this ensures first byte reading
this can check two states i find
so.. sometimes the software doesnt check a disconected vpp pin
om in read but write fails on the first byte or two etc

i clean the pins with a burnish pencil first
to ensure connection
as only write uses this pin on the eprom

---------
[url=H**P://WWW.EZDIA.COM/EPAD/2013-MERCEDES-BENZ-SL-CLASS-PRICE-REVIEWS/7980/] 2013 MERCEDES BENZ SL-CLASS [/url]
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.17 sec. Snitz Forums 2000