MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 GQ-4X4 not reading TMS27C010A correctly
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

anniel

1996 Posts

Posted - 04/25/2016 :  09:57:44  Show Profile  Reply with Quote
Same computer, same USB port and cable, same TMS27C010A. Latest software and drivers. Reading with GQ-4X4 gives different results than GQ-4X and takes double the time.
What's wrong?

Reply #1

anniel

1996 Posts

Posted - 04/25/2016 :  15:28:28  Show Profile  Reply with Quote
I can read it correctly when selecting MBM27C1001 and the VPP LED lights up while reading.
Go to Top of Page
Reply #2

ZLM

2923 Posts

Posted - 04/26/2016 :  17:55:22  Show Profile  Reply with Quote
Checked the devices.txt and found those two chips were assigned to slightly different algorithm.

If you use MBM27C1001 can read and write the TMS27C010A, then the current software assigned the algorithm need to be changed.

Please confirm you can read and write the TMS27C010A with the MBM27C1001.

Go to Top of Page
Reply #3

pfctuning

5 Posts

Posted - 04/27/2016 :  01:57:27  Show Profile  Reply with Quote
Hello everyone, I have to read two 32-pin EEPROM plcc from a vw golf 4 1.9tdi 110cv whit GQ-4X USB RE7.7 and EEPROM I wrote:

TI - 10FMT

B 58911

LX88A9PROP

Id doing the programmer recognize it as TMS27C010A but if I read it with this model and join the two ll hh files and comes out a file unrecognizable in 2d and they told me to read it with MBM27C1001 model and combining the two and ll hh file out of a file with the right information, but in 2d I find strange differences with an original of an official database files, you can help select the right model for reading?
Furthermore the adapter and use 'the ASQ906 model and' correct?
Go to Top of Page
Reply #4

anniel

1996 Posts

Posted - 04/27/2016 :  02:40:35  Show Profile  Reply with Quote
ZLM I only read on the GQ-4X4 and when I saw the resulting file was incorrect I switched to the original GQ-4X (using TMS27C010A algorithm I think) to finish the job correctly. Later on, out of curiosity I tried other "compatible" devices to try to read a known TMS27C010A and found the MBM27C1001 algorithm was reading correctly but the VPP LED lights up while reading. When time allows I'll do write tests and post the results here.
Go to Top of Page
Reply #5

pfctuning

5 Posts

Posted - 04/27/2016 :  02:48:22  Show Profile  Reply with Quote
your adapter you're using to read this plcc and 'the ASQ906?
Go to Top of Page
Reply #6

anniel

1996 Posts

Posted - 04/27/2016 :  03:20:20  Show Profile  Reply with Quote
No adapter, it's a DIP.
Go to Top of Page
Reply #7

pfctuning

5 Posts

Posted - 04/27/2016 :  06:29:06  Show Profile  Reply with Quote
it's' PLCC31 TO DIP32 ADP-005?
Go to Top of Page
Reply #8

pfctuning

5 Posts

Posted - 04/27/2016 :  06:30:33  Show Profile  Reply with Quote
scuse me repeat

it's' PLCC32 TO DIP32 ADP-005?
Go to Top of Page
Reply #9

anniel

1996 Posts

Posted - 04/27/2016 :  06:55:59  Show Profile  Reply with Quote
Yes ADP-005 should work for your PLCC TMS27C010A.
Go to Top of Page
Reply #10

pfctuning

5 Posts

Posted - 04/27/2016 :  07:02:26  Show Profile  Reply with Quote
Ok thanks perfect now i have resolved the problem are this adapter why my are adapter compatibli ASQ906 but don't' go,whit ADP-005 ok.
Go to Top of Page
Reply #11

anniel

1996 Posts

Posted - 04/29/2016 :  07:16:12  Show Profile  Reply with Quote
What is an "ASQ906"?
Go to Top of Page
Reply #12

anniel

1996 Posts

Posted - 04/30/2016 :  15:40:54  Show Profile  Reply with Quote
ZLM, I cannot write TMS27C010A correctly on GQ-4X4 with TMS27C010A nor MBM27C1001 selected in software.
On a freshly burnt TMS27C010A (with original GQ-4X and TMS27C010A selected in software) I can correctly read as TMS27C010A or MBM27C1001 on GQ-4X4 (VPP LED still goes on with MBM27C1001 selected).
Is GQ-4X4 more sensible to bit creep?
My original read was on a vintage burn.
Test cycles are long...
As you may know TMS chips are longer to erase and some jobs are more pressing than tests...
Where that leaves us? Its not bad chips as they go fine with the original GQ-4X. Its not bad contact since other chips work OK.
I find that many EPROM chips are longer to read and write on the GQ-4X4, is that normal?

Edited by - anniel on 04/30/2016 16:45:16
Go to Top of Page
Reply #13

ZLM

2923 Posts

Posted - 04/30/2016 :  23:44:49  Show Profile  Reply with Quote
Yes. The VPP LED ON works as expected on MBM27C1001 selected. Because the device line has RVPP="5V". That means turn on the 5V VPP when reading.

I tested my TMS27C010A on GQ-4x4 and did not find anything wrong.

What is your error message when you writing the TMS27C010A ?

Go to Top of Page
Reply #14

anniel

1996 Posts

Posted - 05/01/2016 :  04:30:51  Show Profile  Reply with Quote
I was unable to get a consistent read with the original data on the chip but once written with fresh data reading is ok.

For the write error message, I dont have my notes right now. I'll be back later with the info.
Go to Top of Page
Reply #15

anniel

1996 Posts

Posted - 05/01/2016 :  05:30:25  Show Profile  Reply with Quote
Just checked a TMS27C010A and it reads different each times as a TMS27C010A (data is somewhat near the actual values) but reads correctly as a MBM27C1001.
Go to Top of Page
Reply #16

anniel

1996 Posts

Posted - 05/01/2016 :  05:31:04  Show Profile  Reply with Quote
Voltage settings?
Go to Top of Page
Reply #17

anniel

1996 Posts

Posted - 05/01/2016 :  05:43:27  Show Profile  Reply with Quote
I added this line to customdevices.txt and it reads ok...

Name="TMS27C010A test",ID="97D6",Class="27C010",Category="EPROM",MFG="TI",RVPP="5V";
Go to Top of Page
Reply #18

anniel

1996 Posts

Posted - 05/01/2016 :  05:45:25  Show Profile  Reply with Quote
Now I'm out of blanc TMS27C010A.
Go to Top of Page
Reply #19

ZLM

2923 Posts

Posted - 05/02/2016 :  19:47:40  Show Profile  Reply with Quote
I believe you found the problem.

Checked datasheet on TMS27C010A, the VPP pin must be high during the reading.

The original device line does not have RVPP="5V"; That will cause the reading not stable.

See following char from the datasheet.

TMS27C0101A working modes:

130029 bytes
Go to Top of Page
Reply #20

anniel

1996 Posts

Posted - 05/03/2016 :  02:31:15  Show Profile  Reply with Quote
Yes, that's where I found the info. VPP also needs to be active to verify. I will need to test write when time permits.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.17 sec. Snitz Forums 2000