MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 Using The Enhanced/Dual power Willem Programmer
 Reading chip SST27sf512
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Sproket

10 Posts

Posted - 08/04/2007 :  09:56:43  Show Profile  Reply with Quote
I use this chip in my honda accord to run it. I have dual programmer also. I can write to the chip and it runs my car so I know its working fine. Then I read the chip and try to pull the data up and I get file cant open. The bin file is good going into chip and runs car. It does read the chip and finish. Using Willem 0.97ja software.

Thanks
Reply #1

ZLM

2926 Posts

Posted - 08/04/2007 :  13:14:00  Show Profile  Reply with Quote
If your file name is ended with .bin, then you have to select file type as .bin.

if it does not open, then post the exact error message here.
Go to Top of Page
Reply #2

Sproket

10 Posts

Posted - 08/04/2007 :  14:46:19  Show Profile  Reply with Quote
Yes I select bin. It says Invalid file: Could notload file.
Go to Top of Page
Reply #3

Sproket

10 Posts

Posted - 08/04/2007 :  14:56:09  Show Profile  Reply with Quote
Let me explain a little more.

I get the error when I try to open the file in my tuning software.

The file is fine when I burn it, then I read it from chip and it does not open. So something has to be changing when I burn it, like maybe the header or something. Or maybe its a setting within my Willem Eprom software.

Go to Top of Page
Reply #4

ZLM

2926 Posts

Posted - 08/04/2007 :  20:17:33  Show Profile  Reply with Quote
can you post you file here?
Go to Top of Page
Reply #5

Sproket

10 Posts

Posted - 08/05/2007 :  00:09:21  Show Profile  Reply with Quote
Here is one of the files that was created in Crome software. I use it and edit it in Crome. After I burned it then read it, it no longer works in Crome.

www.crldomain.com\honda\1.bin
or goto
www.crldomain.com\honda
Go to Top of Page
Reply #6

ZLM

2926 Posts

Posted - 08/05/2007 :  07:24:11  Show Profile  Reply with Quote
Tested the file is opened without any problem.

Steps:
1. goto www.crldomain.com\honda
2. save the 1.bin to local c:\ drive
3. run the 0.j7a software
4. select device SST27SF512 from the software
5. open the file "1.bin" form local c: drive

The software shows the 1.bin file loaded.

Then you can erase the chip and write the data into the chip.


Go to Top of Page
Reply #7

Sproket

10 Posts

Posted - 08/05/2007 :  09:44:45  Show Profile  Reply with Quote
I know you can load the bin file in Willem software and burn/write it to chip.

What Im saying is that the file was originally created in Crome and when I write it to chip, then read it from chip something changes b/c I cant load the file back into Crome if its read off of chip.
Go to Top of Page
Reply #8

ZLM

2926 Posts

Posted - 08/07/2007 :  08:32:49  Show Profile  Reply with Quote
It seems your chip not been write correctly.

Check the checksum in the software. It must be same when you read from the chip and load from the file.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.17 sec. Snitz Forums 2000