MCUmall EPROM BIOS Chip Burner Forum
MCUmall EPROM BIOS Chip Burner Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MCUmall Forums
 True USB Willem Programmer (GQ-2X, GQ-3X, GQ-4X)
 GQ 4x Initialization Problem
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

eurico-br

16 Posts

Posted - 10/08/2019 :  17:48:27  Show Profile  Reply with Quote
Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)
Reply #1

anniel

2209 Posts

Posted - 10/09/2019 :  02:41:23  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?
Go to Top of Page
Reply #2

eurico-br

16 Posts

Posted - 10/09/2019 :  08:23:34  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?



Yes, any version of driver or software! But after format the computer and new windows copy works again!
Go to Top of Page
Reply #3

eurico-br

16 Posts

Posted - 10/09/2019 :  08:33:56  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?



Yes, any version of driver or software! But after format the computer and new windows copy works again!



I tried making the windows restoration to 7 days before the error! but not works. When this occours in the first time i tried many things and not work. Just works after new windows!
Go to Top of Page
Reply #4

anniel

2209 Posts

Posted - 10/09/2019 :  12:11:18  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?



Yes, any version of driver or software! But after format the computer and new windows copy works again!

Failing hard drive?
Go to Top of Page
Reply #5

anniel

2209 Posts

Posted - 10/09/2019 :  12:11:30  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?



Yes, any version of driver or software! But after format the computer and new windows copy works again!



I tried making the windows restoration to 7 days before the error! but not works. When this occours in the first time i tried many things and not work. Just works after new windows!

There is clearly something that changes in your Windows software after some time.
Go to Top of Page
Reply #6

eurico-br

16 Posts

Posted - 10/10/2019 :  14:58:21  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?



Yes, any version of driver or software! But after format the computer and new windows copy works again!



I tried making the windows restoration to 7 days before the error! but not works. When this occours in the first time i tried many things and not work. Just works after new windows!

There is clearly something that changes in your Windows software after some time.



I will re-install the windows in next week!
Go to Top of Page
Reply #7

anniel

2209 Posts

Posted - 10/11/2019 :  02:56:22  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?



Yes, any version of driver or software! But after format the computer and new windows copy works again!



I tried making the windows restoration to 7 days before the error! but not works. When this occours in the first time i tried many things and not work. Just works after new windows!

There is clearly something that changes in your Windows software after some time.



I will re-install the windows in next week!

Also look at your hard drive.
Go to Top of Page
Reply #8

eurico-br

16 Posts

Posted - 10/12/2019 :  15:42:48  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?



Yes, any version of driver or software! But after format the computer and new windows copy works again!



I tried making the windows restoration to 7 days before the error! but not works. When this occours in the first time i tried many things and not work. Just works after new windows!

There is clearly something that changes in your Windows software after some time.



I will re-install the windows in next week!

Also look at your hard drive.



I use SSD, maybe it a problem?
Go to Top of Page
Reply #9

anniel

2209 Posts

Posted - 10/13/2019 :  07:02:28  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?



Yes, any version of driver or software! But after format the computer and new windows copy works again!



I tried making the windows restoration to 7 days before the error! but not works. When this occours in the first time i tried many things and not work. Just works after new windows!

There is clearly something that changes in your Windows software after some time.



I will re-install the windows in next week!

Also look at your hard drive.



I use SSD, maybe it a problem?

There is definitely something wrong with your PC if its configuration changes by itself.
Go to Top of Page
Reply #10

eurico-br

16 Posts

Posted - 10/17/2019 :  06:45:48  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

Hi!!

I have a constant problem in my GQ-4x, it works normally per 6/8 months, and from night to day, the programmer stop to works, appears a initial screen but after show a message saying that the programmer fail to start and no buttons works! I just can make the gq4x works again re-installing the windows 8.1 and re-installing the drivers and software of gq4x.
I try to unistall the software and install again and not works. I deleted any information of gq4x on windows registre and install again and not works! just works again in new windows copy!

Have other way to solve it?

Thanks!!!

:)

Does this happen after an update? Any other software?



Yes, any version of driver or software! But after format the computer and new windows copy works again!



I tried making the windows restoration to 7 days before the error! but not works. When this occours in the first time i tried many things and not work. Just works after new windows!

There is clearly something that changes in your Windows software after some time.



I will re-install the windows in next week!

Also look at your hard drive.



I use SSD, maybe it a problem?

There is definitely something wrong with your PC if its configuration changes by itself.



Its so strange!
Go to Top of Page
Reply #11

anniel

2209 Posts

Posted - 10/17/2019 :  07:54:32  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br


Its so strange!

Certainly.
Go to Top of Page
Reply #12

eurico-br

16 Posts

Posted - 11/14/2019 :  08:55:13  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by eurico-br


Its so strange!

Certainly.



PC formated, new Windows, and the same problem with GQ-4X

"Initialization failed. Please reconnect."

I dont know more what i have to make to solve it!

And my car is stoped!

maybe the solution is just a new programmer?
Go to Top of Page
Reply #13

eurico-br

16 Posts

Posted - 11/18/2019 :  09:30:04  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br


Its so strange!

Certainly.



PC formated, new Windows, and the same problem with GQ-4X

"Initialization failed. Please reconnect."

I dont know more what i have to make to solve it!

And my car is stoped!

maybe the solution is just a new programmer?



I sent a message to suport MCUMALL and they never respond!
Go to Top of Page
Reply #14

anniel

2209 Posts

Posted - 11/18/2019 :  09:50:41  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br


Its so strange!

Certainly.



PC formated, new Windows, and the same problem with GQ-4X

"Initialization failed. Please reconnect."

I dont know more what i have to make to solve it!

And my car is stoped!

maybe the solution is just a new programmer?

Did you try another USB port and cable? Is it a heavily used programmer? The USB connector can also be bad.
Go to Top of Page
Reply #15

anniel

2209 Posts

Posted - 11/18/2019 :  09:51:20  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br


Its so strange!

Certainly.



PC formated, new Windows, and the same problem with GQ-4X

"Initialization failed. Please reconnect."

I dont know more what i have to make to solve it!

And my car is stoped!

maybe the solution is just a new programmer?



I sent a message to suport MCUMALL and they never respond!

Try to call them.
Go to Top of Page
Reply #16

eurico-br

16 Posts

Posted - 11/20/2019 :  09:54:09  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br


Its so strange!

Certainly.



PC formated, new Windows, and the same problem with GQ-4X

"Initialization failed. Please reconnect."

I dont know more what i have to make to solve it!

And my car is stoped!

maybe the solution is just a new programmer?

Did you try another USB port and cable? Is it a heavily used programmer? The USB connector can also be bad.



I tried two cables, and i tried tree USB ports! And the problem was the same.

I will try in another computer.

In 2018, occurred the same problem, I formatted the computer and works again, but now dont works after formatted.
Go to Top of Page
Reply #17

eurico-br

16 Posts

Posted - 11/20/2019 :  09:55:54  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br


Its so strange!

Certainly.



PC formated, new Windows, and the same problem with GQ-4X

"Initialization failed. Please reconnect."

I dont know more what i have to make to solve it!

And my car is stoped!

maybe the solution is just a new programmer?



I sent a message to suport MCUMALL and they never respond!

Try to call them.



Its the unique way! or buy another!
Go to Top of Page
Reply #18

eurico-br

16 Posts

Posted - 11/20/2019 :  10:04:38  Show Profile  Reply with Quote
The strange thing is that the USB drivers are correct, windows recognizes the device, the GQ software recognizes the device, opens the startup window, and then after the startup window closes, the message appears in the status bar that start Failed!


"Ready
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
Initialization failed. Please reconnect.
DEVICE M28F102
<<M28F102>>
Load
Unknown command.
This software is updated already."

Edited by - eurico-br on 11/20/2019 10:09:20
Go to Top of Page
Reply #19

anniel

2209 Posts

Posted - 11/20/2019 :  10:45:37  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br


Its so strange!

Certainly.



PC formated, new Windows, and the same problem with GQ-4X

"Initialization failed. Please reconnect."

I dont know more what i have to make to solve it!

And my car is stoped!

maybe the solution is just a new programmer?

Did you try another USB port and cable? Is it a heavily used programmer? The USB connector can also be bad.



I tried two cables, and i tried tree USB ports! And the problem was the same.

I will try in another computer.

In 2018, occurred the same problem, I formatted the computer and works again, but now dont works after formatted.

Yes, try another computer to rule that out, if problem persists look at the USB connector.
Go to Top of Page
Reply #20

anniel

2209 Posts

Posted - 11/20/2019 :  10:45:42  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br


Its so strange!

Certainly.



PC formated, new Windows, and the same problem with GQ-4X

"Initialization failed. Please reconnect."

I dont know more what i have to make to solve it!

And my car is stoped!

maybe the solution is just a new programmer?



I sent a message to suport MCUMALL and they never respond!

Try to call them.



Its the unique way! or buy another!

It's the best way to contact them.
Go to Top of Page
Reply #21

anniel

2209 Posts

Posted - 11/20/2019 :  10:45:54  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

The strange thing is that the USB drivers are correct, windows recognizes the device, the GQ software recognizes the device, opens the startup window, and then after the startup window closes, the message appears in the status bar that start Failed!


"Ready
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
Initialization failed. Please reconnect.
DEVICE M28F102
<<M28F102>>
Load
Unknown command.
This software is updated already."


Why does it check twice for new software?
Go to Top of Page
Reply #22

eurico-br

16 Posts

Posted - 11/22/2019 :  14:50:40  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

The strange thing is that the USB drivers are correct, windows recognizes the device, the GQ software recognizes the device, opens the startup window, and then after the startup window closes, the message appears in the status bar that start Failed!


"Ready
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
Initialization failed. Please reconnect.
DEVICE M28F102
<<M28F102>>
Load
Unknown command.
This software is updated already."


Why does it check twice for new software?



I dont know!

So strange this problem!
Go to Top of Page
Reply #23

anniel

2209 Posts

Posted - 11/23/2019 :  06:10:35  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

The strange thing is that the USB drivers are correct, windows recognizes the device, the GQ software recognizes the device, opens the startup window, and then after the startup window closes, the message appears in the status bar that start Failed!


"Ready
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
Initialization failed. Please reconnect.
DEVICE M28F102
<<M28F102>>
Load
Unknown command.
This software is updated already."


Why does it check twice for new software?



I dont know!

So strange this problem!

Look at the USB jack on the programmer.
Go to Top of Page
Reply #24

eurico-br

16 Posts

Posted - 11/25/2019 :  16:11:03  Show Profile  Reply with Quote
quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

The strange thing is that the USB drivers are correct, windows recognizes the device, the GQ software recognizes the device, opens the startup window, and then after the startup window closes, the message appears in the status bar that start Failed!


"Ready
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
Initialization failed. Please reconnect.
DEVICE M28F102
<<M28F102>>
Load
Unknown command.
This software is updated already."


Why does it check twice for new software?



I dont know!

So strange this problem!

Look at the USB jack on the programmer.



USB jack cleaned and same problem!

And the suport respond "This model is discontinued for several years, the service is no longer available. "

Is for to have to buy a new programmer!
Go to Top of Page
Reply #25

laptech

United Kingdom
46 Posts

Posted - 11/26/2019 :  02:31:38  Show Profile  Reply with Quote
To make sure your GQ-4x is working properly, confirm that what you see in the screenshots matches that of your computer.

1 - Programmer detected in device manager:

Image Insert:

83933 bytes

2 - Device driver is detected and working properly:

Image Insert:

141793 bytes

3 - GQ-4X Program runs properly:

Image Insert:

144942 bytes

The next two steps will only work if the GQ-4X is detected properly (i am not 100% sure about this though)

4 - Run Detect Hardware:

From the GQ-4X program, on the menu bar click on 'Test H/W' then on the drop down box select 'Detect Hardware', if working the following should appear:-

Image Insert:

158283 bytes

5 - Test GQ-4X voltages:

From the GQ-4X program, on the menu bar click on 'Test H/W' then on the drop down box select 'Voltage Diagnostic', run the test and if working the following should appear:-

Image Insert:

179447 bytes

I am running windows 10 and as you can see by the screenshots, the GQ-4X is detected by the computer because it shows up in the device manager and you can see the device driver is running OK. This means that the USB hardware on the computer and the GQ-4X and the USB cable connecting them both are working. It also shows that the device driver was installed properly and is working properly.

For your GQ-4X to work, step 1 & 2 need to be working. If what you see on your screen is not the same as what you see in the screenshots then you have a hardware/device driver problem. If they are the same then you can move onto step 3 which shows the GQ-4X program running.

To confirm if the GQ-4X program and programmer are working you need to run 'Detect Hardware' which is under Test H/W on the programs menu bar. If the program can see the programmer it will display what you see in step 4, a box saying 'Device detected' and the serial number of your device. If your programmer is not detected then it means there is an issue with the software and programmer detecting one another. As has been mentioned in other forum posts, this detection will fail if the programmer is a fake one. There are many fake GQ-4X being sold which causes a lot of problems with the genuine device drivers and software that is downloaded from the official support site. Is your GQ-4X a genuine one purchased from MCUmall?

The last step tests the integrity of the programmer by checking if all the voltages are working. If any of these fail then the programmer is faulty.

There is something i have probably missed. I am not official support, just some who has the same programmer who is trying to help.

Laptronics UK LTd. Specialist motherboard repair.
Go to Top of Page
Reply #26

anniel

2209 Posts

Posted - 11/26/2019 :  05:20:26  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

The strange thing is that the USB drivers are correct, windows recognizes the device, the GQ software recognizes the device, opens the startup window, and then after the startup window closes, the message appears in the status bar that start Failed!


"Ready
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
Initialization failed. Please reconnect.
DEVICE M28F102
<<M28F102>>
Load
Unknown command.
This software is updated already."


Why does it check twice for new software?



I dont know!

So strange this problem!

Look at the USB jack on the programmer.



USB jack cleaned and same problem!

And the suport respond "This model is discontinued for several years, the service is no longer available. "

Is for to have to buy a new programmer!

Solders are good, no broken pins or traces?
Go to Top of Page
Reply #27

anniel

2209 Posts

Posted - 11/26/2019 :  05:22:25  Show Profile  Reply with Quote
quote:
Originally posted by laptech

To make sure your GQ-4x is working properly, confirm that what you see in the screenshots matches that of your computer.

1 - Programmer detected in device manager:

Image Insert:

83933 bytes

2 - Device driver is detected and working properly:

Image Insert:

141793 bytes

3 - GQ-4X Program runs properly:

Image Insert:

144942 bytes

The next two steps will only work if the GQ-4X is detected properly (i am not 100% sure about this though)

4 - Run Detect Hardware:

From the GQ-4X program, on the menu bar click on 'Test H/W' then on the drop down box select 'Detect Hardware', if working the following should appear:-

Image Insert:

158283 bytes

5 - Test GQ-4X voltages:

From the GQ-4X program, on the menu bar click on 'Test H/W' then on the drop down box select 'Voltage Diagnostic', run the test and if working the following should appear:-

Image Insert:

179447 bytes

I am running windows 10 and as you can see by the screenshots, the GQ-4X is detected by the computer because it shows up in the device manager and you can see the device driver is running OK. This means that the USB hardware on the computer and the GQ-4X and the USB cable connecting them both are working. It also shows that the device driver was installed properly and is working properly.

For your GQ-4X to work, step 1 & 2 need to be working. If what you see on your screen is not the same as what you see in the screenshots then you have a hardware/device driver problem. If they are the same then you can move onto step 3 which shows the GQ-4X program running.

To confirm if the GQ-4X program and programmer are working you need to run 'Detect Hardware' which is under Test H/W on the programs menu bar. If the program can see the programmer it will display what you see in step 4, a box saying 'Device detected' and the serial number of your device. If your programmer is not detected then it means there is an issue with the software and programmer detecting one another. As has been mentioned in other forum posts, this detection will fail if the programmer is a fake one. There are many fake GQ-4X being sold which causes a lot of problems with the genuine device drivers and software that is downloaded from the official support site. Is your GQ-4X a genuine one purchased from MCUmall?

The last step tests the integrity of the programmer by checking if all the voltages are working. If any of these fail then the programmer is faulty.

There is something i have probably missed. I am not official support, just some who has the same programmer who is trying to help.



Thank you laptech, nice tutorial!
Go to Top of Page
Reply #28

eurico-br

16 Posts

Posted - 11/28/2019 :  16:10:32  Show Profile  Reply with Quote
quote:
Originally posted by laptech

To make sure your GQ-4x is working properly, confirm that what you see in the screenshots matches that of your computer.

1 - Programmer detected in device manager:

Image Insert:

83933 bytes

2 - Device driver is detected and working properly:

Image Insert:

141793 bytes

3 - GQ-4X Program runs properly:

Image Insert:

144942 bytes

The next two steps will only work if the GQ-4X is detected properly (i am not 100% sure about this though)

4 - Run Detect Hardware:

From the GQ-4X program, on the menu bar click on 'Test H/W' then on the drop down box select 'Detect Hardware', if working the following should appear:-

Image Insert:

158283 bytes

5 - Test GQ-4X voltages:

From the GQ-4X program, on the menu bar click on 'Test H/W' then on the drop down box select 'Voltage Diagnostic', run the test and if working the following should appear:-

Image Insert:

179447 bytes

I am running windows 10 and as you can see by the screenshots, the GQ-4X is detected by the computer because it shows up in the device manager and you can see the device driver is running OK. This means that the USB hardware on the computer and the GQ-4X and the USB cable connecting them both are working. It also shows that the device driver was installed properly and is working properly.

For your GQ-4X to work, step 1 & 2 need to be working. If what you see on your screen is not the same as what you see in the screenshots then you have a hardware/device driver problem. If they are the same then you can move onto step 3 which shows the GQ-4X program running.

To confirm if the GQ-4X program and programmer are working you need to run 'Detect Hardware' which is under Test H/W on the programs menu bar. If the program can see the programmer it will display what you see in step 4, a box saying 'Device detected' and the serial number of your device. If your programmer is not detected then it means there is an issue with the software and programmer detecting one another. As has been mentioned in other forum posts, this detection will fail if the programmer is a fake one. There are many fake GQ-4X being sold which causes a lot of problems with the genuine device drivers and software that is downloaded from the official support site. Is your GQ-4X a genuine one purchased from MCUmall?

The last step tests the integrity of the programmer by checking if all the voltages are working. If any of these fail then the programmer is faulty.

There is something i have probably missed. I am not official support, just some who has the same programmer who is trying to help.



I make all that you show on the screenshots!
My driver works, the programmer pass on the voltage test.

Apparently, its a original MCUmall programmer!
I sent my serial number to MCUmall suport, and they inform thats the programmer was discontinued.
Go to Top of Page
Reply #29

eurico-br

16 Posts

Posted - 11/28/2019 :  16:12:33  Show Profile  Reply with Quote

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

The strange thing is that the USB drivers are correct, windows recognizes the device, the GQ software recognizes the device, opens the startup window, and then after the startup window closes, the message appears in the status bar that start Failed!


"Ready
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
Initialization failed. Please reconnect.
DEVICE M28F102
<<M28F102>>
Load
Unknown command.
This software is updated already."


Why does it check twice for new software?



I dont know!

So strange this problem!

Look at the USB jack on the programmer.



USB jack cleaned and same problem!

And the suport respond "This model is discontinued for several years, the service is no longer available. "

Is for to have to buy a new programmer!

Solders are good, no broken pins or traces?



The welds, everything is god! However I remembered that 2 days before the problem started, the programmer fell to the ground! Could this be the cause?
Go to Top of Page
Reply #30

anniel

2209 Posts

Posted - 11/28/2019 :  16:59:50  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br


quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

quote:
Originally posted by anniel

quote:
Originally posted by eurico-br

The strange thing is that the USB drivers are correct, windows recognizes the device, the GQ software recognizes the device, opens the startup window, and then after the startup window closes, the message appears in the status bar that start Failed!


"Ready
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
H/W Re: -(SW Re. 6.38)
USB Driver Re.2.0
Software Re. 6.38
Checking new software on server...
Initialization failed. Please reconnect.
DEVICE M28F102
<<M28F102>>
Load
Unknown command.
This software is updated already."


Why does it check twice for new software?



I dont know!

So strange this problem!

Look at the USB jack on the programmer.



USB jack cleaned and same problem!

And the suport respond "This model is discontinued for several years, the service is no longer available. "

Is for to have to buy a new programmer!

Solders are good, no broken pins or traces?



The welds, everything is god! However I remembered that 2 days before the problem started, the programmer fell to the ground! Could this be the cause?

Look for hairline cracks in the PCB.
Go to Top of Page
Reply #31

laptech

United Kingdom
46 Posts

Posted - 11/29/2019 :  01:24:31  Show Profile  Reply with Quote
quote:
Originally posted by eurico-br



The welds, everything is god! However I remembered that 2 days before the problem started, the programmer fell to the ground! Could this be the cause?



The programmer was dropped on the floor and it stopped working!!!!. Why did you not say this in your first post back in August!!!, why has it taken you nearly 3 months to inform us of that very important information!!!!.

If this is how people are, i give up on my help because they do not deserve it...what a waste of time.

Laptronics UK LTd. Specialist motherboard repair.
Go to Top of Page
Reply #32

anniel

2209 Posts

Posted - 11/29/2019 :  04:19:17  Show Profile  Reply with Quote
quote:
Originally posted by laptech

quote:
Originally posted by eurico-br



The welds, everything is god! However I remembered that 2 days before the problem started, the programmer fell to the ground! Could this be the cause?



The programmer was dropped on the floor and it stopped working!!!!. Why did you not say this in your first post back in August!!!, why has it taken you nearly 3 months to inform us of that very important information!!!!.

If this is how people are, i give up on my help because they do not deserve it...what a waste of time.

Yes, this is how humans are...
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
MCUmall EPROM BIOS Chip Burner Forum © Copyright 2003 - 2009 Mcumall Electronics Inc. Go To Top Of Page
Generated in 0.34 sec. Snitz Forums 2000